Address bar does not update when switching tabs if homepage is set to blank.

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Gil, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050122 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050122 Firefox/1.0+

if you set your homepage to blank (about:blank)
and later on create a few tabs
the address bar does not update when switching tabs.

Reproducible: Always

Steps to Reproduce:
1.set your homepage to blank.
2.create a few tabs
3.type different site addresses in the address bar 
4.the address bar won't update when switching tabs.

Actual Results:  
The address bar didn't update when switching tabs.

Expected Results:  
switch the address according to each tab.
Works for me using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050122 Firefox/1.0+

How do you create new tabs (Ctrl+T, File->New Tab, New Tab button)?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Works for me using:
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050122
Firefox/1.0+
> 
> How do you create new tabs (Ctrl+T, File->New Tab, New Tab button)?

(In reply to comment #1)
> Works for me using:
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050122
Firefox/1.0+
> 
> How do you create new tabs (Ctrl+T, File->New Tab, New Tab button)?

(In reply to comment #1)
> Works for me using:
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050122
Firefox/1.0+
> 
> How do you create new tabs (Ctrl+T, File->New Tab, New Tab button)?

(Reporter)

Comment 3

13 years ago
sorry, messed up with the reply a bit.. first time with bugzilla ^^.
I create them with CTRL + T.

Comment 4

13 years ago
I can't reproduce this problem either, is this still an issue? Do you have any
extensions installed, if so have you tried running in Firefox safe mode?

Comment 5

13 years ago
Works for me using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.8) Gecko/20050511
Firefox/1.0.4

Sometimes (rather often) adress bar updates as it should, but I can't find any
dependancy. A have TabMix Extension installed, but disabling it doesn't help.

BTW, when adress bar doesn't show the correct URL of active tab, the "Search on
current page" doesn't work. Typed word is being searched somewhere in other
tabs, and highlighted in background. This is the most annoing thing...

Comment 6

13 years ago
I've found the plugin casusing the trouble. It is Extended Statusbar v1.0 &
v1.2-enh ( http://www.extensionsmirror.nl/index.php?showtopic=1328 ). After
deinstalling it this bug has disapeared.
Resolving as WorksForMe. Gil, if you can still reproduce this using a recent
build with no extensions, please reopen.
Assignee: bugs → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.