If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Not user friendly for visually impaired

RESOLVED FIXED

Status

()

Core
Disability Access APIs
--
major
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: cmesa4, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

My husband uses Jaws for Windows to read the computer as he is blind. It works
with Internet Explorer but not with Mozilla Firefox.
He would very much like to use it as it is better.

Reproducible: Always

Steps to Reproduce:
1.Usual steps
2.
3.

Actual Results:  
Does not read the page properly. Reads a small bit. Not usable for him.



Expected Results:  
Should read page well top to bottom  and be able to be moved around on the page.
moving to correct product
Assignee: myk → firefox
Component: User Interface → General
Product: Bugzilla → Firefox
QA Contact: default-qa → general
There's a new plugin for JAWS to work with Firefox (I think).

Full story here: http://www.wats.ca/articles/firefoxandjaws/71

Updated

13 years ago
Assignee: firefox → aaronleventhal
Component: General → Disability Access APIs
Product: Firefox → Core
QA Contact: general → accessibility-apis
Version: unspecified → Trunk
(Assignee)

Comment 3

13 years ago
I'm actively addressing this problem, but it requires some assistance from
screen reader vendors. We need more than questsions answered -- we need them to
make changes.

Can you also contact Freedom Scientific, the makers of JAWS, and indicate that
you want to use Firefox?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Assignee)

Comment 5

12 years ago
JAWS 7 and Window-Eyes 5.5 will support Gecko 1.8 and Firefox 1.5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
3rd party application got updated, not Mozilla code itself.  (Should probably
have been Tech Evangelism.)

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

12 years ago
I just spent since late 2004 putting the MSAA and keyboard support into Mozilla
so visually impaired users could use it. So, this should be marked FIXED.
(Assignee)

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED

Comment 8

12 years ago
> I just spent since late 2004 putting the MSAA support into Mozilla

Fair enough, my mistake.  (Although no mention of that was made in the comments
of this bug or its resolution. :)

If you could reference the bug responsible for checking in that code that would
be great.

Comment 9

12 years ago
Sorry again, I do see your comment 3 in this bug now.
(Assignee)

Comment 10

12 years ago
All the bugs under Core -> Disability Access APIs for starters.
You need to log in before you can comment on or make changes to this bug.