Closed Bug 279530 Opened 15 years ago Closed 15 years ago

Thunderbird doesn't use "...lowest common denominator character set possible..."

Categories

(Thunderbird :: General, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: black.fox, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041220 K-Meleon/0.9
Build Identifier: Mozilla Thunderbird version 1.0 (20041206)

I'm using Thunderbird 1.0 (Windows distribution). It's not a localized version.
I can see that Thunderbird, starting from version 0.8, does not use the lowest
common denominator character set possible (RFC 2046). It means that Thunderbird
verions starting from 0.8 always use charset that is set by configutarion even
when sending messages that do not contain any 8-bit characters. I use Polish
language and ISO-8859-2 charset in Thunderbird. When sending messages that
contain only US-ASCII chracters Thunderbird still uses ISO-8859-2. There is no
such situation when using Mozilla 1.7.5 or other Mozilla releases. Mozilla in
the same situation uses US-ASCII charset.

Reproducible: Always
This behaviour was changed in bug 247958. If you want, you can enable the
previous lowest common denominator charset behaviour by setting the pref
mail.label_ascii_only_mail_as_us_ascii to true.
(In reply to comment #1)

> This behaviour was changed in bug 247958. If you want, you can enable the
> previous lowest common denominator charset behaviour by setting the pref
> mail.label_ascii_only_mail_as_us_ascii to true.

OK. Thanks. I didn't notice.
Regards

*** This bug has been marked as a duplicate of 247958 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Actually this isn't a dupe of bug 247958, it's the exact opposite of it.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → WONTFIX
(In reply to comment #3)

> Actually this isn't a dupe of bug 247958, it's the exact opposite of it.

No, it isn't but the solvation is almost the same - using
mail.label_ascii_only_mail_as_us_ascii - and can be changed quite easy by the
user. I suggest to include this option using GUI options in Thunderbird - it is
IMO the best compromise.
You need to log in before you can comment on or make changes to this bug.