If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Right-clicking in a edit box cancels a hilighted area and prevents cut/copy/paste/delete

RESOLVED DUPLICATE of bug 279496

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 279496
13 years ago
9 years ago

People

(Reporter: Ryuichi KUBUKI, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050123 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050123 Firefox/1.0+

Right-clicking in a edit box cancels a hilighted area. Because of this you can't
copy/cut/paste/delete in edit boxes only with the mouse.

Reproducible: Always

Steps to Reproduce:
1. Enter a text line in a text area
2. Select it by dragging the mouse or Shift+Arrow
3. Right-click to spawn the context-menu to cut/copy/paste/delete it

Actual Results:  
The hilight immediately disappears and the cut/copy/paste/delete in the
context-menu are grayed out.

Expected Results:  
The hilight stays there and the context-menu shows the cut/copy/paste/delete.

20050116 was okay IIRC.

Comment 1

13 years ago
related to bug 279496 ?
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 279496 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.