If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No information about supported standarts

RESOLVED WONTFIX

Status

Documentation
Web Developer
RESOLVED WONTFIX
13 years ago
3 years ago

People

(Reporter: Artem Skoretskiy, Unassigned)

Tracking

Details

(Whiteboard: http://www.webdevout.net/ ;)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.5) Gecko/20041108 Firefox/1.0

I'm a web-developer, and then i develop sites it is very important, what
standarts are supported by that browser.

So, I suggest to add in Help section of menu item "Supported standarts", where
all supported  standarts will be listed. It would be perfect, if it will be
tree, and its subitems will show exact methods or types ot it.

For example

* HTML 1
* HTML 2
* HTML 3
* HTML 4
* xHTML 2
* XSLT 2
* DOM
  * appendChild
  * createNode
* CSS
  * cursor
  * background-color
  * background

etc..

Well, it could be placed at mozilla.org, and item will lead to it, but it would
be better to place such information right in browser.

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
The developers section of the website:

http://www.mozilla.org/docs/web-developer/

does have some info on supported standards.  Perhaps not a perfect "this is what
Mozilla does" list, but better than nothing. 
(Reporter)

Comment 2

13 years ago
Well, you're right - it is better than nothing, but it isn't enough!

That page describes how to develop for Mozilla - related Guides, Tutorials, etc,
but not the list of standards.

For example, CSS 2, CSS 3, XSLT are supported (at least partially) but not
listed in that document. Naturally, no description of supported tags, atributes
and etc are present.

Also, read it - "W3C's CSS2.1 Specification (partly supported by Mozilla)". So,
what part of it is actually supported?

I think that this subject is still actual.

Comment 3

13 years ago
Far enough.  I wonder if the information is better placed somewhere in the
developers section of the website, rather than in the help system of the
browser.  There is quite a lot to cover to do the job properly (as you point
out), so I wonder if the help is the best place.
(In reply to comment #3)
> Far enough.  I wonder if the information is better placed somewhere in the
> developers section of the website, rather than in the help system of the
> browser.  There is quite a lot to cover to do the job properly (as you point
> out), so I wonder if the help is the best place.

This indeed does not belong in the help system.  This information is only useful
to web developers.  Most Firefox users are not web developers, so it would only
be useless information and would bloat the download size.  Additionally, there
are plenty of web developer documents on mozilla.org already that, for the most
part, cover what is requested here.

The problem with listing what parts of the standards are unsupported is that the
situation is so fluid.  Fixes occur every day, and any such document will likely
be at least partially obsolete within a month (and certainly whenever the next
stable release comes out).  You may never see exactly what you want because it's
well-nigh impossible.

Anyways, tho, that's discussion for elsewhere.  I'm transferring this into
Documentation, where it can be considered in greater detail.  (I'm not marking
it as new, however, because I haven't really taken the time to look for duplicates.)
Assignee: jwalden+fxhelp → web.developer
Component: Help Documentation → Web Developer
Product: Firefox → Documentation
QA Contact: help-documentation
(Reporter)

Comment 5

13 years ago
You're right, might be browser's help system is not the best place for that
information.

But, existing information DOESN'T cover the subject! From these site you won't
know what technologies you can you for web building for FF.

So, I must insist on making such list.

Also, as you've said in comment #4, nobody can say what standards are supported
by Mozilla in a moment! Even developers doen't know what are implemented my browser!

As a result, implementing standards are slow and partial.

I suggest more than a "web-site section for developers" - I suggest
implementation of browser-self diagnostics (self-information), that provides
information about implemented standards. Maybe it would be something like
about:standard . As an example, I can refer to OpenGL - one of its method
returns all of supported standards (shaders, etc).

So, if we implement that feature i expect better standards compliance, better
transparency for web-developers (and Mozilla developers !) and advanced users
that are interested to have "best" browser that supports more and better standards.

Then, i guess, Documentation is not the right place for it, isn't it?

Comment 6

13 years ago
bug 14339 is about links to relevant standards

I tried to do it but soon abandoned the idea. Just a mere list of relevant
standards will have like 50+ links. I just don't see how pages like this can be
useful to anyone. With our limited resources, it would be better to write as
many tutorials/guides as possible and link to what we have.

From discussion here, I think everyone agrees with me on this. So how about
wontfix this and file separate bugs for specific docs?
(Reporter)

Comment 7

13 years ago
There is no need to put links to supported standards. Just list them.

Why it is useful for people: so, here is a developer that wants to implement
some features in his company's web-site. He needs to know what standards are
supported by FF - so he decide which to use. For example, I as a developer was
woundered when i knew that XSLT are supported at FF. If i knew it before, i made
my site in XML+XSLT instead of HTML. Also, it would be great to know, what parts
(for example) of XSLT are supported.
(Reporter)

Comment 8

13 years ago
Actually, I have a huge goal submitting this bug - FF needs COMPLETE support for
the most of web-standards. Often arises situations when some parts of standards
are not supported (align for column, atribute charof, etc).

I have a feeling that only interesting (for FF developers) parts of standards
are implemented. Other parts are implemented only when someone founds it and
submit a bug. I think it is wrong.

There should be a system, that guidelines implementation of new standards - that
indicates what exact standards (and exact parts of them) are implemented and
(maybe) which parts are not.

Comment 9

12 years ago
I think I understand what Artyom says. Is this the kind of page
http://www.opera.com/docs/specs/
that you would like to see in somewhere at mozilla.org?
Creating such page would involve a huge, considerable amount of time, efforts,
maintenance energy and it would most likely lead to more demands, detailed info,
with more cross-linked references, etc...

There has to be a good and solid justification for such efforts to start with. I
agree with you: such documentation would be nice, most likely useful... but such
efforts of creating such documentation would necessitate lots of efforts.
Personally, I see other much more pressing priorities in the areas of
documentation and there are not so many people actively involved these days in
the documentation areas.
(Reporter)

Comment 10

12 years ago
(In reply to comment #9)
> I think I understand what Artyom says. Is this the kind of page
> http://www.opera.com/docs/specs/

Yes, that's condensed version of what I want. :-) But it should be actualy enough.

You are more skilled it management and it is not first-pripritet task. But I
think it should be done somewhen. And I guess a lot of discrepancy to standards
will be found.

Comment 11

12 years ago
Artyom,

Here is a wonderful and amazing website with all supported standards for Firefox 1.x:

http://www.webdevout.net/
(HTML 4.01, XHTML 1.x, CSS 2.1 and CSS 3, DOM 2 and 3, ECMAscript, etc.)
and for a summary
http://www.webdevout.net/browser_support_summary.php

The amazing thing is that the info can be copied, modified, and distributed freely as long as it attributes the original author and maintains the Creative Common license. 
And there is a edition mode which can be triggered via mouse by any visitor. So, that way, you can submit conveniently any changes or feedback regarding a particular property/method/feature in any table. 

So, Mozilla.org or MDC could use all those tables and put it somewhere at Mozilla Developer Center ( http://developer.mozilla.org/ ) possibly in the Web standards category ( http://developer.mozilla.org/en/docs/Web_Standards )

Adding http://www.webdevout.net/ to status board . I have updated the CSS1 Mozilla bug file on my own 6 months ago.

CONFIRMING, marking as NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: http://www.webdevout.net/ ;
(Reporter)

Comment 12

12 years ago
(In reply to comment #11)
> Here is a wonderful and amazing website with all supported standards for

Yes, that's a great resource, but:

Not *ALL* standards are listed there:
- no information about XML technologies XSLT, XPath, XForms, (etc.),
- no information about supported image types - SVG, PNG, etc.
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.