Improve second-level sorting for top rated and newest extensions/themes lists

RESOLVED FIXED in 1.0

Status

addons.mozilla.org Graveyard
Public Pages
--
enhancement
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: Alex Sirota (iosart), Assigned: morgamic)

Tracking

unspecified

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If two extensions/themes have exactly the same user rating average, they are
sorted by name. This is pretty arbitrary and not really useful for the end user,
IMHO. Should one item be listed before another on the 'top' list simply because
it precedes it alphabetically? It would be better to sort by some real metric,
like download count. 
So, if two extensions/themes have exactly the same rating average, the one that
is more popular will be listed first. The above is true for both '5 top rated'
and the full list. 

Another example of arbitrary and unfair sorting is with newest 'Top 8'
extensions/themes. For example, suppose that 12 extensions are added on a
particular day. The order by which they are actually added (the DateAdded
field), is pretty arbitrary, and so 4 out of the 12 added extensions won't have
a chance to appear on the 'Newest Top 8' list. Here, I would suggest another
solution: first sort by the date added (only by date, not time) and then by
random(). This way all the items added on a particular day will have an equal
chance to be on the list. 
Further improvement would be to show a random list of 8 items added during the
last week. This will allow the users to be exposed to a wider variety of new
extensions, and will give new and useful extensions a better chance of "getting
off the ground".

The "Most Popular" lists don't suffer from the above problems, because it is
highly unlikely that two items will have exactly the same download count.


Reproducible: Always

Steps to Reproduce:

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

13 years ago
Assignee: Bugzilla-alanjstrBugs → alex

Comment 1

13 years ago
I think this is just the tip of the iceberg in terms of problems with "top rated
extensions."  Listing extensions by average rating is fundamentally flawed, and
it should be removed entirely.  As it is now, the system is useless as it is
just an alphabetical listing of the first 5 extensions.  Just a waste of space.

But it will be downright destructive when commenting is turned back on.  People
will go to any lengths to game a system where items are sorted by average
ratings.  I've seen it happen.  They will write scripts to rate their extensions
5 stars.  These scripts will waste resources, and start slowing down UMO for
everyone.  And ultimately this top 5 list will be a ranked list of who is the
best spammer.

I think the top 5 rated should be eliminated and replaced with 5 more popular to
make it top 10 most popular.  As the previous poster mentions, the current
system for ranking popularity of extensions is great, and incredibly useful for
new people coming to UMO.

Comment 2

13 years ago
Created attachment 176221 [details] [diff] [review]
Patch to extensions/index.php to fix this bug

This patch gets rid of the "top 5 rated" which does not serve any useful
purpose.  In its place, it extends the top 5 most popular to the top 10 most
popular.  Also, the titles for "Most Popular" and "Newest Extensions" are now
linked to the complete list of each for the sake of improved navigation.

Updated

13 years ago
Attachment #176221 - Flags: first-review?

Updated

13 years ago
Attachment #176221 - Flags: first-review? → first-review?(mike.morgan)
(Assignee)

Comment 3

13 years ago
Comment on attachment 176221 [details] [diff] [review]
Patch to extensions/index.php to fix this bug

My only reservation is that "most downloaded" can be abused just as much as
comments / ratings can.  You could just as easily argue for the other side of
the equation; that a more restrictive commenting / rating system (like cnet or
amazon) is more valuable because it is quantitative by nature -- and not just a
number.

In the future, I'd like to see both download counts and rating show up as
intuitively sortable fields.  That won't happen tomorrow, though.

In order to curb comment spam and also offer a wider range of options (instead
of just 5 either way) I think it would be a good idea to increase both
categories by 5 and adjust their ORDER BY clauses to compliment each other.

That said, until the spam is handled, let's hide the ratings, then sort by
popularity, rating, name.

I felt there could be more done for the page overall, so I will grant this -
and submit another patch.

BTW - I didn't put in the category link since the sidebar makes it redundant.
Attachment #176221 - Flags: first-review?(mike.morgan) → first-review-
(Assignee)

Comment 4

13 years ago
Created attachment 179685 [details] [diff] [review]
Rewritten, reduced extensions page.

This is a suggestive patch that covers more of the page.  It yanks out some of
the compat information, but it makes for a simpler "gimme all you got" page for
first-time or returning users alike.
(Assignee)

Comment 5

13 years ago
TODO - Make the category links go to their respective category pages
(showlist.php?category=foofoo).

TODO - Link should go to offset 10 (start at 11-20 since 1-10 is already on the
first page they see).
Assignee: alex → mike.morgan

Comment 6

13 years ago
Created attachment 179688 [details] [diff] [review]
3rd attempt to fix this bug
Attachment #176221 - Attachment is obsolete: true
Attachment #179688 - Flags: first-review?(mike.morgan)
(Assignee)

Comment 7

13 years ago
Comment on attachment 179688 [details] [diff] [review]
3rd attempt to fix this bug

I'd like to use this as a template for how Themes should look as well.
Attachment #179688 - Flags: first-review?(mike.morgan) → first-review+
(Assignee)

Updated

13 years ago
Attachment #179685 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.