When the only open window is the Download Manager, menu's do not work.

RESOLVED DUPLICATE of bug 249003

Status

()

Toolkit
Downloads API
--
major
RESOLVED DUPLICATE of bug 249003
14 years ago
10 years ago

People

(Reporter: Marijn de Jong, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.5 (KHTML, like Gecko) Safari/125.12
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041108 Firefox/1.0 (PowerBook)

In Mac OS X you always have the menu bar at the top of the window corresponding to the open 
application. When in Firefox the only open window is the Download manager the menu's on this bar do 
not work. 

After closing the download manager the menu's are accessible again.

When I have a browser window and the download manager open, the menu's also work.

Reproducible: Always

Steps to Reproduce:
1. Download a file
2. Leave Download manager open, close all other windows
3. Click any (File, Help and so on) menu.
Actual Results:  
The menu label becomes colored, no menu opens

Expected Results:  
Menu opening.
So many possible places to dup to that it's hard to pick one (translation:
please search before reporting bugs: even ignoring existing duplicate bugs,
there are already too many open bugs for this one behavior). There's the real
core issue, bug 21296, or bug 249003 to work around it, or bug 245206 that's
competing with it, or bug 239218 which seems to be the exact same thing as its
blocker.

*** This bug has been marked as a duplicate of 249003 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.