Mail & Newsgroups, choosing as default mail client, setting doesn't stick, dialog reappears on subsequent startups.

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: Harvey Savage, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050124 MultiZilla/1.7.0.0f
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050124 MultiZilla/1.7.0.0f

Mail & Newsgroups, 
Trying to choose Mozilla as the default mail client,
The setting doesn't stick, 
Dialog window to choose as default reappears on subsequent startups.

Last worked properly in build 05011906.exe, doesn't work in builds up to and
including 05012405.exe.

Reproducible: Always

Steps to Reproduce:
1.select as default email client.
2.close, restart email client.
3.dialog box to select as default reappears every time.

Actual Results:  
Nothing, had to re-choose as email client.

Expected Results:  
Selection should stick with no re-appearing dialog boxes.

Comment 1

13 years ago
This behaviour was probably caused by the Checkin for Bug 277833 at 2005-01-19. 

I have seen it too at this time. Workaround is to startup Mozilla with
Administrator-Rights one time and register as Default Mail Application.

The Builds after 2005011914 have changed my entry for URL:MailTo-Protocol, so I
missed my added Argument -P "MyProfile" in the shell-open command, have to bring
it back while editing the Registry.

Comment 2

13 years ago
xref bug 245532.

Comment 3

13 years ago
Also xref bug 250675, which is probably more appropriate to this bug.

Updated

13 years ago
Keywords: regression
Version: unspecified → Trunk
(Reporter)

Comment 4

13 years ago
This bug in recent builds has nothing to do with user permissions.  I am the
single, only user, there are no other profiles on this box.

The bug is in Mozilla, the build 05011906.exe, issued, dated Jan. 19 works as it
always has, no restrictions.  All newer builds have a problem with retaining the
client choice parameter.

Comment 5

13 years ago
Confirming with Mozilla trunk build 2005013106 on Windows XP SP2.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Flags: blocking1.8b?

Updated

13 years ago
Flags: blocking1.8b? → blocking1.8b+
Severity: normal → major

Updated

13 years ago
Flags: blocking1.8b+ → blocking1.8b2+
(Reporter)

Comment 6

13 years ago
I just upgraded one of my computers, Win98 to Win2k, hard disk format to NTFS. 
Mozilla builds after Jan. 19, show the same inability to retain the default
email client choice.  The older build, downloaded Jan. 19, operates normally,
retains my chosen selections upon restarting.

hrs
Assignee: sspitzer → mscott
*** Bug 282918 has been marked as a duplicate of this bug. ***
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050219] (nightly) (W98SE)

Not a right issue, on W98SE single user.
v1.8a5 still works as expected.
(Assignee)

Comment 9

13 years ago
Well, what that Jan 19th checkin appears to have done was to convert Mozilla to
use the Thunderbird version of the set as default mail client code. I notice
that no UI was added to make the Suite the default news application. Anyway,
1. Are those people with problems able to set Thunderbird as the default
2. If that stays set, are they then able to set Mozilla back as default?
3. Will Set Program Access and Defaults set Mozilla as the default?
4. If you immediately reopen preferences has the checkbox already unchecked?
(In reply to comment #9)
> 1. Are those people with problems able to set Thunderbird as the default
Yes (prefs dialog says TB is set as default mail app and if you click on a
mailto: link in IE or Firefox, TB gets opened, too).

> 2. If that stays set, are they then able to set Mozilla back as default?
Partly (i think). If i click Yes to set Mozilla MailNews as default mail app, i
don't see the checkbox in Thunderbird for default mail app checked anymore (and
Thunderbird reprompts me if it should set itself as the default mail app). The
checkbox for default news app remains so (Mozilla doesn't seem to touch that
setting). However if i click on a mailto: link in IE (or Firefox), i either get
Error, check if mail program is properly installed (IE) or nothing happens
(Firefox).

> 3. Will Set Program Access and Defaults set Mozilla as the default?
If you mean the Windows panel, i don't see Mozilla or Thunderbird there (maybe
because i use zip builds and self built cvs).

> 4. If you immediately reopen preferences has the checkbox already unchecked?
If i check the checkbox "Use Mozilla Mail as the default mail application" (in
Mozilla prefs), click OK and then reopen prefs, the check is gone.
(Assignee)

Comment 11

13 years ago
Hmm... it looks as if someone who knows what the registry entries should be
needs to check what Outlook/OE, Thunderbird and Mozilla actually set them to...
(Assignee)

Comment 12

13 years ago
(In reply to comment #10)
>The checkbox for default news app remains so (Mozilla doesn't seem to touch
that setting).
Although someone could easily implement this... as soon as this bug is fixed...
Ok, i think i know what's missing :) (i compared two regmon logs), it's
basically this:
94	3.28415371	thunderbird.exe:3064	CreateKey	HKCR\mailto\shell	SUCCESS	Key:
0xE13E3620	
95	3.28416377	thunderbird.exe:3064	EnumerateValue
HKLM\Software\Clients\Mail\Mozilla Thunderbird\Protocols\mailto\shell	NOMORE		
96	3.28417522	thunderbird.exe:3064	EnumerateKey
HKLM\Software\Clients\Mail\Mozilla Thunderbird\Protocols\mailto\shell	SUCCESS
Name: open	
97	3.28419785	thunderbird.exe:3064	OpenKey	HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open	SUCCESS	Key: 0xE2FF9700	
98	3.28426322	thunderbird.exe:3064	CreateKey	HKCR\mailto\shell\open	SUCCESS
Key: 0xE35834A0	
99	3.28427356	thunderbird.exe:3064	EnumerateValue
HKLM\Software\Clients\Mail\Mozilla Thunderbird\Protocols\mailto\shell\open	NOMORE		
100	3.28428585	thunderbird.exe:3064	EnumerateKey
HKLM\Software\Clients\Mail\Mozilla Thunderbird\Protocols\mailto\shell\open
SUCCESS	Name: command	
101	3.28430876	thunderbird.exe:3064	OpenKey	HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open\command	SUCCESS	Key: 0xE3478100	
102	3.28441101	thunderbird.exe:3064	CreateKey	HKCR\mailto\shell\open\command
SUCCESS	Key: 0xE3771400	
103	3.28442805	thunderbird.exe:3064	EnumerateValue
HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open\command\	SUCCESS
"C:\DOKUME~1\MCSMUR~1.MCS\DESKTOP\TB-TRUNK\THUNDE~1\THUNDE~1.EXE -compose %1"	
104	3.28444286	thunderbird.exe:3064	EnumerateValue
HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open\command\	SUCCESS
"C:\DOKUME~1\MCSMUR~1.MCS\DESKTOP\TB-TRUNK\THUNDE~1\THUNDE~1.EXE -compose %1"	
105	3.28452974	thunderbird.exe:3064	SetValue
HKCR\mailto\shell\open\command\(Default)	SUCCESS
"C:\DOKUME~1\MCSMUR~1.MCS\DESKTOP\TB-TRUNK\THUNDE~1\THUNDE~1.EXE -compose %1"	
106	3.28454175	thunderbird.exe:3064	EnumerateValue
HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open\command	NOMORE		
107	3.28455237	thunderbird.exe:3064	EnumerateKey
HKLM\Software\Clients\Mail\Mozilla
Thunderbird\Protocols\mailto\shell\open\command	NOMORE		
108	3.28457164	thunderbird.exe:3064	CloseKey	HKCR\mailto\shell\open\command
SUCCESS	Key: 0xE3771400	

Mozilla needs to set HKEY_CLASSES_ROOT\mailto\shell\open\command\(Default) to
"path to mozilla.exe -compose %1". Then Mozilla doesn't ask anymore if it should
set itself as the default mail client and the check for default mail app in the
preferences window is also checked. mailto: links open fine from IE and Firefox
in Mozilla then.

Comment 14

13 years ago
(In reply to comment #13)

Sorry to break the news to you, but this method does NOT work.
I created that key ('cause it was somehow missing).
started mozilla-->mail and it DID ask me if I wanted it to be the default mail
app.I selected "yes", closed mozilla, opened regedit and the key was gone again.
It's not only that mozilla can not be set as the default mail app, in fact, it
REMOVES that condition for ANY installed mail client that may have been selected
as the default (because it just deletes the registry key, no matter what).

Comment 15

13 years ago
I did a little experiment, I st OE (puaj!) as the default mail app, started
mozilla, answered "yes" to the question, closd mozilla and the regkey was gone,
so   now not only mozilla isn't my default mail app, but in fact, there isn't any...

Comment 16

13 years ago
(In reply to comment #13)
> Mozilla needs to set HKEY_CLASSES_ROOT\mailto\shell\open\command\(Default) to
> "path to mozilla.exe -compose %1". Then Mozilla doesn't ask anymore if it
> should set itself as the default mail client and the check for default mail
> app in the preferences window is also checked.

If that's true, this bug is dependent on bug 202497, which has a patch in 
progress that Scott has been stalling on for over a year (HINT HINT) and which 
Asa just recently asked him if he could like, y'know, get it into the trunk 
(HINT HINT).
(Reporter)

Comment 17

13 years ago
(In reply to comment #16)
> 
> If that's true, this bug is dependent on bug 202497, which has a patch in 
> progress that Scott has been stalling on for over a year (HINT HINT) and which 
> Asa just recently asked him if he could like, y'know, get it into the trunk 
> (HINT HINT).

I can only reiterate, this problem started after the build produced on Jan. 19.
All builds after that date will not retain that setting and I have downloaded
and installed all of them after the 19th up to and including the build for Feb.
22.  Without exception I have to re-install 05011906.exe to retain the default
email client setting, and I do, it's too much hassle to reselect that setting
each time.

Comment 18

13 years ago
> Mozilla needs to set HKEY_CLASSES_ROOT\mailto\shell\open\command\(Default) to
> "path to mozilla.exe -compose %1". Then Mozilla doesn't ask anymore if it should
> set itself as the default mail client and the check for default mail app in the
> preferences window is also checked. mailto: links open fine from IE and Firefox
> in Mozilla then.

I still haven't been able to reproduce this behavior yet, but I don't think this
registry setting is the problem. We are correctly adding the following key when
the app is set as the default mail app:

HKEY_LOCAL_MACHINE\Software\Classes\mailto\shell\open\command
with the value:
C:\BUILD\TREES\DBG\MOZILLA\DIST\BIN\mozilla.EXE -compose %1

So that's happening like it should. It must be something else.

HKEY_LOCAL_MACHINE\
Status: NEW → ASSIGNED
(In reply to comment #18)
> HKEY_LOCAL_MACHINE\Software\Classes\mailto\
> with the value:
> C:\BUILD\TREES\DBG\MOZILLA\DIST\BIN\mozilla.EXE -compose %1
> 
> So that's happening like it should. It must be something else.

Well, here it doesn't. When i start Thunderbird (and click on Yes to make TB the
default mail client), this reg key is created with the proper value. But when i
start Mozilla MailNews and click on Yes to make itself the default mail client,
it deletes this reg sub-key/tree (everything under mailto).

Comment 20

13 years ago
Using a debug suite build from today. Started up, asked to become default said
yes. Walked through all the registry keys getting created under
HKEY_LOCAL_MACHINE and all were added correctly. Quit, restarted, was not asked
again, mozilla suite was still listed as the default mail client, registry key
values were still intact. Repeated 3 times, was never re-prompted.

Maybe this problem is an operating system / not the right admin permissions
level bug? 

I'm on Win XP with Full admin permissions to write values into the registry.

Comment 21

13 years ago
(In reply to comment #20)
> Maybe this problem is an operating system / not the right admin permissions
> level bug? 
> 
> I'm on Win XP with Full admin permissions to write values into the registry.

Comment 8 reports the problem with Windows 98, which doesn't have different 
rights for different users.
(Reporter)

Comment 22

13 years ago
(In reply to comment #20)
> Using a debug suite build from today. Started up, asked to become default said
> yes. Walked through all the registry keys getting created under
> HKEY_LOCAL_MACHINE and all were added correctly. Quit, restarted, was not asked
> again, mozilla suite was still listed as the default mail client, registry key
> values were still intact. Repeated 3 times, was never re-prompted.
> 
> Maybe this problem is an operating system / not the right admin permissions
> level bug? 
> 
> I'm on Win XP with Full admin permissions to write values into the registry.

I must refer you to reply/comments 4 and 6.

This is XP Home SP1, didn't want the hassle of SP2.  I'm the only user, full admin.

If what you surmise were true I should have the same problem with the Jan. 19
build that I saved when this started.  It's the only build that has worked since
then.
(Assignee)

Comment 23

13 years ago
Try removing or changing this value, then restarting Mozilla:
HKEY_LOCAL_MACHINE\Software\Mozilla\Desktop\registeredAsMailApp
If that does not work, then what do you have for this key:
HKEY_LOCAL_MACHINE\Software\Clients\Mail\Mozilla\Protocols\mailto

Updated

13 years ago
Blocks: 283348
Removing registeredAsMailApp didn't work. The entry
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\shell\open\command
 has the value "path to mozilla.exe -compose %1". Furthermore i have a entry
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\(URL Protocol)
which is empty and
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\(Default) with
the value "URL:MailTo Protocol" (and a entry named
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\DefaultIcon,
but that's not related here i guess).
Created attachment 175642 [details]
(Win98) RegMon from a5-1122, before dialog

This one will work fine after selecting Yes.
Created attachment 175649 [details]
(Win98) RegMon from b2-0223, before dialog

This one will not work after selecting Yes.

The RegMon log is the same whether it's the first run after a5-1122,
or I already answered Yes then closed and relaunched MAS.

NB: I start Navigator, then log the MailNews opening only.

****

The differences:

|HKLM\Software\Mozilla - Test Key| test happens earlier:
this move should not disturb.

|HKCU\Software\Clients\News + HKLM\Software\Clients\News| part was added:
this enhancement should not disturb, should it ?

|HKLM\Software\Classes\mailto\shell\open\command| was added (in two places):
Could it be this failure which triggers the dialog ??

As a side note, why are we doing twice the |...\MAPI32 to
HKLM\Software\Clients\Mail\Mozilla\Protocols\mailto\shell\open\command| part ?
Likewise, is the double |QueryValueEx| needed for |...\messengerWindow.ico| and
|...\MAPI32| ?

2 other changes that may or may not disturb:
|*\protocols\*| was changd to |*\Protocols\*|;
|HKCU\Software\Clients\Mail| part was changd to |HKLM\Software\Clients\Mail|.

NB: Notice that |registeredAsMailApp| is not involved at all in this log.

(If it's not any of these, then the issue should not be Registry related !?)
(In reply to comment #26)
> |*\protocols\*| was changd to |*\Protocols\*|;

All right, all my other software client settings use 'P':
this seems to have been an intended nit fix :-)
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050223] (nightly) (W98SE)

(In reply to comment #26)
> |HKLM\Software\Classes\mailto\shell\open\command| was added (in two places):
> Could it be this failure which triggers the dialog ??

The answer seems to be Yes in my case:
adding and setting this fixed this bug.


(In reply to comment #18)
> We are correctly adding the following key when
> the app is set as the default mail app:
> 
> HKEY_LOCAL_MACHINE\Software\Classes\mailto\shell\open\command
> with the value:
> C:\BUILD\TREES\DBG\MOZILLA\DIST\BIN\mozilla.EXE -compose %1

Not in my case:
When I answer Yes, MAS recreates |HKLM\Software\Classes\mailto + URL Protocol =
""| as needed,
but does nothing about recreating and setting
|HKLM\Software\Classes\mailto\shell\open\command| !

It sets it under |HKLM\Software\Clients\Mail\Mozilla\...| only.
(Reporter)

Comment 29

13 years ago
(In reply to comment #28 & all others)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050226
MultiZilla/1.7.0.0f
(XPHOME)

> |HKLM\Software\Classes\mailto\shell\open\command| was added (in two places):
> Could it be this failure which triggers the dialog ??
>
> The answer seems to be Yes in my case:
> adding and setting this fixed this bug.

Beginning with the build of (20050120xx.exe, up to and including todays build
(2005022605.exe), none install correctly and retain the email client choice.

Build (2005011906.exe) re-installs correctly every time.  

None of the above builds add the key above/below to the registry, even
(2005011906.exe) doesn't add it, yet, it works.

The below registry key is a work-around posted in one of the previous comments.
 I added it manually to my XP registry and it does allow the newer builds to run
correctly.  I added everything from 'mailto to %1', still, the build of Jan. 19
works without this registry entry.

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto\shell\open\command |default
|c:\mozilla\mozilla.exe -compose %1

Comment 30

13 years ago
I'm sorry, but I will repeat what I said before:
Adding this key to the registry DOES NOT fix the problem, and it doesn't allow
ANY newer build to run correctly.
after running mail and answering "yes", the key vanishes from the registry. just
like that.
(Reporter)

Comment 31

13 years ago
(In reply to comment #30)
> I'm sorry, but I will repeat what I said before:
> Adding this key to the registry DOES NOT fix the problem, and it doesn't allow
> ANY newer build to run correctly.
> after running mail and answering "yes", the key vanishes from the registry. just
> like that.

I beg to differ, it worked on my computer, xphome, as i said, this is a
work-around, without this key mine still wouldn't work.  I tried it, removed the
key and reinstalled, problem returned without the key.  

The key does not disappear from my registry  after installing a new build.  In
fact, with this key in place I do not have to set the default client choice, it
is there when installation completes at first startup.  

Probably because the pref.js setting for that choice is already 'true'.

j

Comment 32

13 years ago
Weird, it does not work  for me. the key just vanishes after running mail/news.
Xp Pro SP2...
Anyway if it works for some and not for others, it's still a BIG BUG that should
be fixed ASAP.
bye!
(Reporter)

Comment 33

13 years ago
(In reply to comment #32)
> Weird, it does not work  for me. the key just vanishes after running mail/news.
> Xp Pro SP2...
> Anyway if it works for some and not for others, it's still a BIG BUG that should
> be fixed ASAP.
> bye!

Very much agree!

Comment 34

13 years ago
Comment 32 and comment 33, please read 
http://www.mozilla.org.uk/temp/etiquette.html

before commenting in the future, thanks
(In reply to comment #29)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050226
> MultiZilla/1.7.0.0f
> (XPHOME)
> 
>  I added it manually to my XP registry and it does allow the newer builds to run
> correctly.  I added everything from 'mailto to %1', still, the build of Jan. 19
> works without this registry entry.

Thanks for the confirmation.

Yet, that's what was said before:
This key fixes it (at least for some people);
The previous builds do not care because they are not checking this key.

What we need now is someone to fix the bug in light of these informations.
(Assignee)

Comment 36

13 years ago
(In reply to comment #24)
>The entry
>HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\shell\open\command
>has the value "path to mozilla.exe -compose %1". Furthermore i have a entry
>HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\(URL Protocol)
>which is empty and
>HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\(Default)
>with the value "URL:MailTo Protocol" (and a entry named
>HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\DefaultIcon
>but that's not related here i guess).
When you try to set Mozilla as the default application, do you see (which of)
these entries listed under HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto\... ?
Can you use the Set Program Access or Internet Options control panel to set
Mozilla as the default application, and if so which entries does that set?
(In reply to comment #36)
> (In reply to comment #24)
> >The entry
>
>HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\shell\open\command
> >has the value "path to mozilla.exe -compose %1". Furthermore i have a entry
> >HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\(URL Protocol)
> >which is empty and
> >HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\(Default)
> >with the value "URL:MailTo Protocol" (and a entry named
> >HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Mozilla\protocols\mailto\DefaultIcon
> >but that's not related here i guess).
> When you try to set Mozilla as the default application, do you see (which of)
> these entries listed under HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto\... ?

If I set it as default mail app via the Yes/No question on MailNews startup,
this key is empty except one key named
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto\URL Protocol, it's empty. If i set it
as default mail app via the checkbox in preferences the key is really empty
(also no URL Protocol key).

> Can you use the Set Program Access or Internet Options control panel to set
> Mozilla as the default application, and if so which entries does that set?

I can't set Mozilla nor Thunderbird there as default app, only Outlook Express :/.

Comment 38

13 years ago
*** Bug 284119 has been marked as a duplicate of this bug. ***

Comment 39

13 years ago
Unfortunately I opened a new bug https://bugzilla.mozilla.org/show_bug.cgi?id=284119
I tried the suggestion on comment
https://bugzilla.mozilla.org/show_bug.cgi?id=279627#c29
(|HKLM\Software\Classes\mailto\shell\open\command|) which works fine with me on
XP SP2. 
Hope that helps solving the problem.
Here is the only content of my registry for this branch
running Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050228

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto]
"URL Protocol"=""

Comment 41

13 years ago
*** Bug 236490 has been marked as a duplicate of this bug. ***
*** Bug 284793 has been marked as a duplicate of this bug. ***

Comment 43

13 years ago
(In reply to comment #42)
> *** Bug 284793 has been marked as a duplicate of this bug. ***

Sorry, don't know how I overlooked this previous
report.  My apologies for wasting others' time.

Philip Taylor
(Assignee)

Comment 44

13 years ago
Created attachment 176652 [details]
Resulting registry settings

OK, so I found a clean computer and compiled Mozilla 1.8b2 on it.
The set as default client does stick in my case.
One other thing you can check: do you have a registry entry
HKEY_LOCAL_MACHINE\Software\Mozilla\Desktop\Mapi_backup_dll
(In reply to comment #44)
> One other thing you can check: do you have a registry entry
> HKEY_LOCAL_MACHINE\Software\Mozilla\Desktop\Mapi_backup_dll

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b) Gecko/20050217] (release) (W98SE)

I do, and its value is: X:\WINDOWS\SYSTEM\Mapi32_moz_bak.dll
And I have two identical files on disk: Mapi32.dll and Mapi32_moz_bak.dll
Version is the last installed one: v1.8b1

(v1.7.5 and v1.8b2-23 are currently installed too.)
(In reply to comment #20)
> Using a debug suite build from today. Started up, asked to become default said
> yes. Walked through all the registry keys getting created under
> HKEY_LOCAL_MACHINE and all were added correctly. Quit, restarted, was not asked
> again, mozilla suite was still listed as the default mail client, registry key
> values were still intact. Repeated 3 times, was never re-prompted.
> 
> Maybe this problem is an operating system / not the right admin permissions
> level bug? 
> 
> I'm on Win XP with Full admin permissions to write values into the registry.

It's no wonder Scott and Neil weren't able to see this bug.

It seems to be an *installer-only problem*, as I just download and ran the
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/mozilla-i586-pc-msvc.zip
build, and this was fine.

Both Scott and Neil (in comment 44) compiled their own Seamonkey builds; can
others please grab the mozilla-i586-pc-msvc.zip build and give it a try?  This
will help the problem to be narrowed down. 

Comment 47

13 years ago
maybe but we don't actually make the client the default in the installer so we'd
never be writing to
HKEY_LOCAL_MACHINE\Software\Classes\mailto\shell\open\command at that point anyway. 

But I'll take a closer look in the morning. 
(In reply to comment #46)
> It's no wonder Scott and Neil weren't able to see this bug.
> It seems to be an *installer-only problem*, as I just download and ran the
> http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/mozilla-i586-pc-
msvc.zip
> build, and this was fine.

I build myself and i also get this problem :)
Created attachment 176762 [details] [diff] [review]
Patch

The buffer was too small, the code was supposed to fix it, but
ERROR_NOT_ENOUGH_MEMORY is the wrong return code. According to
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/sysinfo/base/regenumvalue.asp
ERROR_MORE_DATA is the correct return code.

Updated

13 years ago
Assignee: mscott → bugzilla
Status: ASSIGNED → NEW

Updated

13 years ago
Attachment #176762 - Flags: review?(neil.parkwaycc.co.uk)

Comment 50

13 years ago
wow, that really fixed it? that's pretty funny. Great find Frank. 

Updated

13 years ago
Attachment #176762 - Flags: review?(neil.parkwaycc.co.uk) → review?(mscott)
*** Bug 285764 has been marked as a duplicate of this bug. ***

Comment 52

13 years ago
still getting this bug with the latest nightly :-/
(Assignee)

Comment 53

13 years ago
Created attachment 177304 [details] [diff] [review]
Proposed patch

I thought that the RegCopyKey function was pretty inscrutable so I thought it
would be more realistic to rewrite it. Also as the caller didn't do any error
checking I didn't bother with any internal error checking either. If you want
I could do a fully flexible registry key copier, but that's probably overkill
Assignee: bugzilla → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
Attachment #177304 - Flags: review?(mscott)

Updated

13 years ago
Attachment #176762 - Attachment is obsolete: true
Attachment #176762 - Flags: review?(mscott)
Comment on attachment 177304 [details] [diff] [review]
Proposed patch

>Index: nsMapiRegistryUtils.h
>===================================================================
>RCS file: /cvsroot/mozilla/mailnews/mapi/mapihook/src/nsMapiRegistryUtils.h,v
>retrieving revision 1.10
>diff -u -r1.10 nsMapiRegistryUtils.h
>--- nsMapiRegistryUtils.h	8 Mar 2005 01:17:04 -0000	1.10
>+++ nsMapiRegistryUtils.h	13 Mar 2005 19:18:31 -0000
>@@ -71,7 +71,7 @@
>-    nsresult RegCopyKey(HKEY SrcKey, HKEY TrgKey, const char* TrgSubKeyName); // copies a key and all sub keys to TrgKey.
>+    static void RegCopyKey(HKEY aSrcKey, HKEY aDestKey, const char* aSubKeyName); // copies a key and all sub keys to TrgKey.

Nit: update the comment to |aDestKey| too ;-)

Comment 55

13 years ago
Comment on attachment 177304 [details] [diff] [review]
Proposed patch

thanks Neil.
Attachment #177304 - Flags: superreview+
Attachment #177304 - Flags: review?(mscott)
Attachment #177304 - Flags: review+
(Assignee)

Comment 56

13 years ago
Fix checked in. Fingers crossed ;-)
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Verified FIXED with Windows XP seamonkey trunk build Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050316
Status: RESOLVED → VERIFIED

Comment 58

13 years ago
*** Bug 286604 has been marked as a duplicate of this bug. ***

Comment 59

13 years ago
Works OK with build 2005031706 on Windows 98 SE (Polish)

Comment 60

13 years ago
I found that the default setting stays on with build Mozilla/5.0 (Windows; U;
Win98; en-US; rv:1.8b2) Gecko/20050317, (Win98SE by the way) and I was just
about to cheer when I decided to see if I could turn off the setting by clearing
the checkbox in preferences. The setting seems to stay on even after turning it
off, quitting Mozilla and Windows, and rebooting to apply the new registry settings.

Is anyone else seeing this?
(Assignee)

Comment 61

13 years ago
It's possible that the interim builds have confused it and it doesn't know what
your default client used to be, so it fails to restore it correctly.

Comment 62

13 years ago
Mozilla mail is my only email client. There is no other, as I either uninstalled
Outlook Express or never installed it in recent memory. Dealing with the
registry is a pain, I know, as there are so many useless-junk entries. I saw a
number of Hotmail entries while searching for a Mozilla reference, and I've
NEVER used Hotmail. The wizards who can wade through the registry mess and solve
problems have my great respect.

Comment 63

13 years ago
Using: Mozilla 1.8b2 Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050318

After install over previous version, received dialog box asking if I wanted to 
set Mozilla Mail as default. Said yes, but dialog repeats on every launch. Error
message was:

"Mozilla mail could not be set as the default mail application 
because a registry key could not be updated. Verify with your system
administrator that you have write access to your system registry, and then try
again."

This is win 98SE, never had a problem accessing the registry before.

Installed Outlook Express to see if this would create a necessary registry entry
that Moz could modify, but still received the prompt and error msg on every launch.

Uninstalled OE, now the dialog box does not appear on launch. However if I go to 
preferences and try to set Moz mail as default I get the error message again
saying the registry cannot be changed.

Is it possible that Moz could not assess how many mail apps are available on
install? OE seems to have counted them correctly (2 including self) and on
uninstall left a parameter (1) that Moz can use to see that it alone can act as
mail app and therefore a prompt for default is redundant?
Maybe someone can file a new bug for that issue?

Comment 65

13 years ago
I don't know whether a new bug is necessary -- see bug 109362 comment 13.

Comment 66

13 years ago
Using Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050320, I tried
the default checkbox setting and found that it appears to properly retain the
checked and unchecked state. Haven't tried it on a mailto link.

Comment 67

13 years ago
*** Bug 288982 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.