crash while applet initialization with old java? [@ 0x00000000 - nsLineLayout::ReflowFrame]

RESOLVED DUPLICATE of bug 240105

Status

()

--
critical
RESOLVED DUPLICATE of bug 240105
14 years ago
8 years ago

People

(Reporter: imbaczek, Unassigned)

Tracking

({crash})

1.7 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This has been haunting me for a year or so. There's a headline applet in the
header of http://esreality.com. It sometimes fails to load on my box and all
hell breaks loose if it happens so.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to esreality.com.
2. Manage to close the tab with esr while the applet is loading (it's gray and
stuff.)
3. Watch the fox crash.

Actual Results:  
Crash.

Expected Results:  
Normal operation.

TB3267618G
TB3245170E
TB3228819K

Updated

14 years ago
Assignee: firefox → nobody
Component: General → Layout: Block and Inline
Product: Firefox → Core
QA Contact: general → layout.block-and-inline
Summary: java crash while applet initialization → java crash while applet initialization [@ 0x00000000 - nsLineLayout::ReflowFrame]
Version: unspecified → 1.7 Branch
(Reporter)

Comment 2

14 years ago
BTW, I forgot that sometimes the applet fails to load (applet ... notinited),
the gray stuff gets a red cross instead of the cup and then it's a sure crash -
just close the tab.

I'm not sure if the reasons are all the same, but it's the same applet; I
believe that the talkbacks provided cover both cases (closing during init and
after 'applet notinited.')

Updated

14 years ago
Keywords: crash

Comment 3

14 years ago
See bug 240105. This looks like a duplicate.

Status whiteboard of 240105 says it may be fixed with latest java. Please test
it with FF 1.0.4 and Java Plugin 1.5.0_03 (Java 5 Update 3).
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 5

13 years ago
I don't see any of the problems reported using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060313 Firefox/1.5.0.2 and JRE/Java Plug-in 1.4.2_06 

anyone else able to reproduce with recent updates?

is there anything more that can be investigated on this, or I wonder if we should close this out?

Updated

13 years ago
Summary: java crash while applet initialization [@ 0x00000000 - nsLineLayout::ReflowFrame] → crash while applet initialization with old java? [@ 0x00000000 - nsLineLayout::ReflowFrame]

Updated

13 years ago
Blocks: 353557
(Reporter)

Comment 6

13 years ago
I'm the author of this bug report; it's been fixed a long time ago (even before the offending applet got removed from the site :), probably due to a JRE upgrade.

Comment 7

13 years ago
Isn't this a dupe of 240105?  And shouldn't both be resolved?

Updated

13 years ago
No longer blocks: 353557

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 240105
Crash Signature: [@ 0x00000000 - nsLineLayout::ReflowFrame]
You need to log in before you can comment on or make changes to this bug.