###!!! ASSERTION: Form control has a frame, but it's not a form frame

RESOLVED FIXED

Status

()

Core
Layout: Form Controls
--
trivial
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: mats, Assigned: mats)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

14 years ago
###!!! ASSERTION: Form control has a frame, but it's not a form frame: 'Error',
file nsGenericHTMLElement.cpp, line 2250

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/content/html/content/src/nsGenericHTMLElement.cpp&rev=1.566&root=/cvsroot&mark=2250#2224

STEPS TO REPRODUCE:
1. load testcase
2. click on <select>
3. move mouse over dropdown menu

It only occurs if there is an <optgroup> present
(Assignee)

Comment 1

14 years ago
Created attachment 172314 [details]
Testcase
the problem is that nsHTMLOptGroupElement::HandleDOMEvent calls GetFormControlFrame.

It shouldn't be doing that.  Its frame will NEVER be a form control frame --
it'll be a block.  So it should just call GetPrimaryFrame(PR_FALSE).

Mats, want to fix this?  If not, let me know and I will...
(Assignee)

Updated

14 years ago
Assignee: nobody → mats.palmgren
(Assignee)

Comment 3

14 years ago
Created attachment 173440 [details]
Testcase #2
(Assignee)

Comment 4

14 years ago
Created attachment 173441 [details] [diff] [review]
Patch rev. 1
Attachment #173441 - Flags: superreview?(bzbarsky)
Attachment #173441 - Flags: review?(bzbarsky)
Comment on attachment 173441 [details] [diff] [review]
Patch rev. 1

r+sr=bzbarsky
Attachment #173441 - Flags: superreview?(bzbarsky)
Attachment #173441 - Flags: superreview+
Attachment #173441 - Flags: review?(bzbarsky)
Attachment #173441 - Flags: review+
(Assignee)

Comment 6

14 years ago
Checked in 2005-02-04 20:13 PDT

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.