Firefox/Moz should whitelist dictionaries.mozdev.org

RESOLVED WONTFIX

Status

()

Firefox
Build Config
--
minor
RESOLVED WONTFIX
14 years ago
13 years ago

People

(Reporter: Adam Kennedy, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Went to the dictionary.mozilla.org website and had a popup for the dictionary
downloading blocked.

update, dictionary, and the full set of moz sites should be added to any
whitelists at install time.

Because you have to download the Australian English dictionary separately, it's
the very first thing I do on any installation, and I get caught by this problem
on each computer.

At the very least, you should probably add dictionary.moz to the popup whitelist :)

Thanks

Reproducible: Always

Steps to Reproduce:
1. Install Firefox
2. Open dictionary.mozilla.org
3. Select "English (Australia)"

Actual Results:  
The yellow "a popup was blocked" bar appeared at the top of the screen

Expected Results:  
The popup should have opened

Comment 1

14 years ago
There is no dictionary.mozilla.org.  There is a dictionaries.mozdev.org, which
doesn't have pop-ups, but does have XPIs.  Is that the site you're talking about?

Comment 2

13 years ago
If you're talking about enabling *.mozilla.org, that'll get WONTFIX'd.  Back in
the original whitelisting bug when they were discussing this, I pointed out that
at the least we couldn't allow bugzilla.mozilla.org because anyone could post a
malicious XPI to it.  Even then, the developers here still initially used
*.mozilla.org because my comment was forgotten, and only after someone pointed
it out in a comment in a MozillaZine talkback thread was it fixed to only
update.mozilla.org.

(Of course, if you meant mozdev.org, the bug's WONTFIX because the Foundation
doesn't control it.)
(Reporter)

Comment 3

13 years ago
Ack, yes dictionaries.mozdev.org was probably what I meant.

And it appears they have since removed the popup, so the point is now probably moot.

Feel free to WONTFIX this, but before you do, is there a reason why the
"official" site for dictionaries (it's where Thunderbird sends you when you
"Download More..." in the spell checker) isn't a foundation website?
Changing summary to reflect eventual bug refinement, but at the moment we aren't
whitelisting any non-mozilla.org site. Perhaps the dictionaries should be moved
to update.mozilla.org if the product is pointing people at them.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Summary: Firefox/Moz should install with the complete set of .mozilla.org sites whitelisted → Firefox/Moz should whitelist dictionaries.mozdev.org
You need to log in before you can comment on or make changes to this bug.