mozilla crashes after viewing video with mplayer plugin

RESOLVED WORKSFORME

Status

Plugins Graveyard
Mplayer
--
critical
RESOLVED WORKSFORME
13 years ago
2 years ago

People

(Reporter: Theblueman, Assigned: kdekorte)

Tracking

({crash, qawanted})

Details

(Whiteboard: closeme 2008-05-25)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050120
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050120

After viewing a movie with the mplayer plugin mozilla crashes everytime.

Reproducible: Always

Steps to Reproduce:
1. go to a site with a movie trailer like
http://www.apple.com/trailers/wb/batman_begins/
2. Watch the trailer
3.

Actual Results:  
Mozilla consistently crashes after watching the trailer.


I'm using the latest nightly builds and the latest mplayer plugin (2.75). I
compiled the plugin from source.
Creating a new profile did not prevent mozilla from crashing.  
When I used mozilla 1.75, mozilla did not crash after viewing the trailer.  I
think I read that there was a change in how mozilla handles plugins in version 1.8.
Talkback incident id?  A good start would be knowing whether it's Mozilla
crashing or the plugin...
Summary: mozilla crashes after viewing video with mplayer plugin → mozilla crashes after viewing video with mplayer plugin
(Reporter)

Comment 2

13 years ago
It's pretty frustrating because talkback will not start.  Here is what I get
when I run mozilla from the command line.  The Gtk errors occur when Mozilla
crashes at the end of a trailer:

mozilla]$ ./mozilla
(QFA)Talkback error: Can't initialize.
 
Gtk-CRITICAL **: file gtkwidget.c: line 3824 (gtk_widget_set_events): assertion
`!GTK_WIDGET_REALIZED (widget)' failed.
 
Gtk-CRITICAL **: file gtkwidget.c: line 3824 (gtk_widget_set_events): assertion
`!GTK_WIDGET_REALIZED (widget)' failed.
ADDED URL: the_ring_2_m480.mov
code: 36
 speed 2800
ADDED URL: the_ring_2_m480.mov
code: 36
 speed 2800
./run-mozilla.sh: line 423:  4496 Aborted                 "$prog" ${1+"$@"}
(Reporter)

Comment 3

13 years ago
Correction from my previous post.  The Gtk errors occur when the mplayer plugin
starts - when a movie starts.
Jay, any idea why talkback is failing to initialize here?
(Reporter)

Comment 5

13 years ago
Not sure why but talkback started working perhaps because of a reboot or because
I restarted X server.  Anyway, the most recent talkback ID I sent for this issue
is TB3531185G
The full stack there is:

ld-linux.so.2 + 0xc32 (0x0040ac32)
libc.so.6 + 0x29342 (0x0044b342)
libgcc_s.so.1 + 0x3b25 (0x008deb25)
libgcc_s.so.1 + 0x3f5b (0x008def5b)
libpthread.so.0 + 0xb5ea (0x006b75ea)
libpthread.so.0 + 0x9633 (0x006b5633)
libpthread.so.0 + 0x5d61 (0x006b1d61)
mplayerplug-in.so + 0x1fb47 (0x41b1ab47)
libpthread.so.0 + 0x47fc (0x006b07fc)

so that looks like an mplayer bug....

Updated

13 years ago
Keywords: crash
Version: unspecified → Trunk
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 8

12 years ago
This bug is still valid.  As mentioned before the crash occurs in the latest
nightly builds 1.8. 
1.7 versions do not have this problem.
Keywords: qawanted

Updated

12 years ago
Assignee: general → nobody
Component: General → Plug-ins
Product: Mozilla Application Suite → Core
QA Contact: general → plugins

Updated

12 years ago
Assignee: nobody → kdekorte
(Assignee)

Comment 9

12 years ago
Does this crash happen with mplayerplug-in 3.11? We went thru a crash debug
cycle about version 2.85+
(Reporter)

Comment 10

12 years ago
I'm using the latest seamonkey GTK1 (2005092705), lastest mplayer plugin(3.11)
which I compiled on Fedora 4 and it still crashes after viewing movie preview.
(Assignee)

Comment 11

12 years ago
Can you run the browser under GDB and give a backtrace? With firefox I run it
with the -g option to do this and once it crashes type 'bt' at the gdb prompt.
Have you tried the GTK2 version of the browser and does it crash with that?
Since the plugin works fine with Firefox 1.04 thru 1.07 in both GTK1 and GTK2
modes I'm guessing something may have changes with the new gecko, but without
the backtrace it is hard to tell. 
(Reporter)

Comment 12

12 years ago
I had a lot of problems getting gdb to work properly and I don't think the
results below are of much value.  My lastest talkback ID is TB10050264E.
I compiled the latest version of mplayerplug-in for X so I could use the plugin
in GTK1 or GTK2.
Seamonkey with GTK2 also crashed after viewing a trailer.
I tried DeerPark and it seemed to work without crashing,it is using rv:1.9.
Ever since mozilla 1.8betas have been released I have encountered the bug.
Here is another link that has the problem
http://www.apple.com/trailers/universal/king_kong/
Here is a link that causes all mozilla/firefox to crash
http://www.apple.com/trailers/universal/the40yearoldvirgin/

-----------------------------------------------------

./run-mozilla.sh -g ./seamonkey-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.:./plugins:/usr/local/lib/mre/mre-1.1a
DISPLAY=:0.0
DYLD_LIBRARY_PATH=.:/usr/local/lib/mre/mre-1.1a
     LIBRARY_PATH=.:./components:/usr/local/lib/mre/mre-1.1a
       SHLIB_PATH=.:/usr/local/lib/mre/mre-1.1a
          LIBPATH=.:/usr/local/lib/mre/mre-1.1a
       ADDON_PATH=.
      MOZ_PROGRAM=./seamonkey-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
which: no ddd in (/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin)
/usr/bin/gdb ./seamonkey-bin -x /tmp/mozargs19558
GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) run
Starting program: /home/nowhere/seamonkey/seamonkey-bin
Reading symbols from shared object read from target memory...(no debugging
symbols found)...done.
Loaded system supplied DSO at 0x544000
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 8919520 (LWP 20059)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread 85052336 (LWP 20062)]
[New Thread 27749296 (LWP 20063)]
[New Thread 126946224 (LWP 20064)]
[New Thread 38239152 (LWP 20065)]
[New Thread 50891696 (LWP 20066)]
[New Thread 95542192 (LWP 20067)]
[New Thread 145148848 (LWP 20068)]
[New Thread 155638704 (LWP 20069)]
[Thread 95542192 (LWP 20067) exited]
[Thread 155638704 (LWP 20069) exited]
[New Thread 155638704 (LWP 20070)]
[Thread 145148848 (LWP 20068) exited]
[Thread 27749296 (LWP 20063) exited]
[New Thread 27749296 (LWP 20071)]
checking to see if we need to make a button
n->url=http://movies.apple.com/movies/universal/king_kong/king_kong-teaser_eng_480.mov
url=http://movies.apple.com/movies/universal/king_kong/king_kong-teaser_eng_480.mov
href=(null)
ADDED URL: king_kong-teaser_eng_m480.mov
code: 46
 speed 2800
ADDED URL: king_kong-teaser_eng_m480.mov
code: 46
 speed 2800
Detaching after fork from child process 20072.
[Thread 38239152 (LWP 20065) exited]
[Thread 155638704 (LWP 20070) exited]
[Thread 50891696 (LWP 20066) exited]
checking to see if we need to make a button
n->url=http://movies.apple.com/movies/universal/king_kong/king_kong-teaser_eng_m480.mov
url=http://movies.apple.com/movies/universal/king_kong/king_kong-teaser_eng_480.mov
href=(null)

Program received signal SIGABRT, Aborted.
[Switching to Thread 27749296 (zombie)]
0x00544402 in __kernel_vsyscall ()
(gdb) bt
#0  0x00544402 in __kernel_vsyscall ()
#1  0x0036a118 in raise () from /lib/libc.so.6
#2  0x0036b888 in abort () from /lib/libc.so.6
#3  0x009dede7 in __frame_state_for () from /lib/libgcc_s.so.1
#4  0x009defda in _Unwind_ForcedUnwind () from /lib/libgcc_s.so.1
#5  0x00832c6e in _Unwind_ForcedUnwind () from /lib/libpthread.so.0
#6  0x00830cc7 in __pthread_unwind () from /lib/libpthread.so.0
#7  0x0082ce3c in pthread_exit () from /lib/libpthread.so.0
#8  0x0446286f in playPlaylist (td=0xa902a08) at Source/plugin-threads.cpp:1767
#9  0x0082cb80 in start_thread () from /lib/libpthread.so.0
#10 0x0040c9ce in clone () from /lib/libc.so.6

<Seamonkey completely hung at this point when the movie preview finished>

(gdb) 
(gdb) finish
Run till exit from #0  0x006fdc71 in NSGetModule ()
   from /home/nowhere/seamonkey/components/libprofile.so
Detaching after fork from child process 20074.

Program exited with code 06.

Comment 13

12 years ago
#8  0x0446286f in playPlaylist (td=0xa902a08) at Source/plugin-threads.cpp:1767

if you could have from gdb done:
frame 8
list

that might help me...
(Reporter)

Comment 14

12 years ago
I re-ran with a different movie same result. I typed "frame 8" at the bottom.

<snip>

Detaching after fork from child process 22056.
[Thread 112016304 (LWP 22054) exited]
[Thread 55233456 (LWP 22050) exited]
[Thread 27351984 (LWP 22048) exited]
checking to see if we need to make a button
n->url=http://movies.apple.com/movies/sony_pictures/rent/rent-tlr-r_m480.mov
url=http://movies.apple.com/movies/sony_pictures/rent/rent-tlr-r_480.mov
href=(null)

Program received signal SIGABRT, Aborted.
[Switching to Thread 129395632 (zombie)]
0x00a3b402 in __kernel_vsyscall ()
(gdb) bt
#0  0x00a3b402 in __kernel_vsyscall ()
#1  0x00c05118 in raise () from /lib/libc.so.6
#2  0x00c06888 in abort () from /lib/libc.so.6
#3  0x0042ade7 in __frame_state_for () from /lib/libgcc_s.so.1
#4  0x0042afda in _Unwind_ForcedUnwind () from /lib/libgcc_s.so.1
#5  0x0011cc6e in _Unwind_ForcedUnwind () from /lib/libpthread.so.0
#6  0x0011acc7 in __pthread_unwind () from /lib/libpthread.so.0
#7  0x00116e3c in pthread_exit () from /lib/libpthread.so.0
#8  0x06e5986f in playPlaylist (td=0xa31c4c0) at Source/plugin-threads.cpp:1767
#9  0x00116b80 in start_thread () from /lib/libpthread.so.0
#10 0x00ca79ce in clone () from /lib/libc.so.6
(gdb) frame 8
#8  0x06e5986f in playPlaylist (td=0xa31c4c0) at Source/plugin-threads.cpp:1767
1767        pthread_exit(0);
Current language:  auto; currently c++
(gdb) list
1762
1763        if (DEBUG) {
1764            printf("----player thread: normal exit\n");
1765        }
1766
1767        pthread_exit(0);
1768
1769        return NULL;
1770    }
(Assignee)

Comment 15

12 years ago
Simple questions

1. Are you compiling SeaMonkey and mplayerplug-in with the same compiler?
2. If so what version of the compiler are you using.
3. If not can you do that and see if that makes a difference

Comment 16

12 years ago
kdekorte: why do you bother using pthread_exit?

from man pthread_exit:
An implicit call to pthread_exit() is made when a thread other than the thread
in which main() was first invoked returns from the start routine that was used
to create it. The function's return value shall serve as the thread's exit status.

(not that this really should matter here, i'm just curious).
(Assignee)

Comment 17

12 years ago
mplayer runs inside of a thread inside of mplayerplug-in, so when it completes I
cleanup up the thread. Since, I do a phtread_create I assume I need to do a
pthread_exit. 

Mozilla runs mplayerplug-in which opens a thread to run mplayer so that
mplayerplug-in can control mplayer.

(Reporter)

Comment 18

12 years ago
Answers to Simple questions

1. Are you compiling SeaMonkey and mplayerplug-in with the same compiler?
ans:I'm only compiling mplayer, Seamonkey is downloaded and untared. No
compiling necessary.

2. If so what version of the compiler are you using.
ans:gcc version 4.0.1 20050727 (Red Hat 4.0.1-5)

3. If not can you do that and see if that makes a difference
ans: I've never compiled seamonkey/mozilla.  If I download the latest mozilla1.7
 mplayerplug-in will not crash the browser. 

Comment 19

12 years ago
reporter: about:buildconfig should tell you the compiler used for gecko.

kdekorte: from the docs, it looks like you don't have to do it that way....
(Reporter)

Comment 20

12 years ago
Here is the build config information

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.2.3 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align
-Wno-long-long -pedantic -pthread -pipe
c++ 	gcc version 3.2.3 	-fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread -pipe
-I/usr/X11R6/include

Configure arguments
--enable-application=suite --disable-tests --enable-extensions=default,tasks
--without-system-nspr --without-system-jpeg --without-system-zlib
--without-system-png --without-system-mng --disable-debug '--enable-optimize=-O2
-gstabs+' --enable-crypto --enable-default-toolkit=gtk 
(Assignee)

Comment 21

12 years ago
Ok, I tested Seamonkey today using this version of it

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050913 SeaMonkey/1.0a

All I did is install it and load up a trailer at the Apple site. And no problem
was found. I made no changes to the code and even went back to my Firefox 1.0.7
browser and played the same clip. 

Here is my guess as to what is going on. You are using a gcc 4 compiled plugin
with a gcc 3 browser. This is going to cause you trouble. 

I bet the about:buildconfig from your Firefox mentions gcc 4 and the plugin was
probably compiled with gcc 4.

You can also try grabbing the latest version of mplayerplug-in from CVS (the one
I am using) I have only made a few changes and none of them are related to
threading. 
(Reporter)

Comment 22

12 years ago
You are correct Firefox is built with gcc 4.x.

I Downloaded mozilla 1.7.12 which is compiled with gcc32 and did not experience
the crash.  If the compiler versions is significant, mozilla should have crashed
like seamonkey.  This problem only started when mozilla 1.8 became available.
Since the problem started I have upgraded from Fedora 1, 3 and I am now using 4.
 I am at a loss since it works for you.

I will try the mplayerplug-in from CVS as you suggested and let you know.
(Assignee)

Comment 23

12 years ago
I upgraded my machine from FC3 to FC4 and did some testing. 

I used seamonkey(gcc3) and firefox(gcc4) with a gcc 3 version of mplayerplug-in
and I could not get it to crash. 

I then recompiled mplayerplug-in with gcc4 and retested and it did not crash
there either. So my guess of it being a gcc issue is now eliminated. 

I'm at a loss as to what is wrong now.
(Reporter)

Comment 24

12 years ago
Works with Seamonkey GTK2.
I downloaded the latest Seamonkey GTK2, recompiled mplayerplug-in with the
defaults (./configure --with-gecko-sdk=/home/nowhere/gecko-sdk) and the plugin
works without crashing the browser.
The browser chash occurs only with Seamonkey GTK1.

(Assignee)

Comment 25

12 years ago
Commenting out the pthread_exit at line 1767 in plugin-threads.cpp allows
mplayerplug-in to work in GTK1 and GTK2 mode with seamonkey. This however seems
to be caused by seamonkey and mozilla 1.7 with GTK1 widgets does not crash. I am
going to comment it out in the plugin but I am still wondering WHY I would need
to do that when it has worked with many versions of mozilla up to this point.
(Reporter)

Comment 26

12 years ago
Just wondering if anyone else has tried duplicating this bug using the lastest gtk1 version of seamonkey and the mplayerplug-in.

Comment 27

10 years ago
still fail for anyone with GTK2?
Whiteboard: closeme 2008-05-25
Please reopen if it still occurs in Firefox 3.

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → Mplayer
Product: Core → Plugins
QA Contact: plugins → mplayer
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.