If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unfinished exe file cannot be deleted when cancel a download to Windows Desktop

VERIFIED DUPLICATE of bug 262683

Status

()

Toolkit
Downloads API
--
major
VERIFIED DUPLICATE of bug 262683
13 years ago
9 years ago

People

(Reporter: Yuxuan Wang, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Set the default download directory to Desktop, and download a exe file, and then
cancel it and remove the download. The unfinished file remain on desktop and
cannot be deleted, the dialog is as below:

Error Deleting File or Folder
---------------------------
Cannot delete IPQQ2004II_skycn: It is being used by another person or program.

Close any programs that might be using the file and try again.
---------------------------
OK   
---------------------------

And i can only delete it in Safe Mode.

Reproducible: Always

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 262683 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.0 Branch
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.