On clicking any hyperlink in the central column of the webpage it does not display the html page

RESOLVED INVALID

Status

()

Core
Networking
RESOLVED INVALID
13 years ago
9 years ago

People

(Reporter: molecularbiophysics, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

Try clicking on any hyperlink in the central column of the website
http://www.nature.com/nsmb (with cgi-taf protocol in them) for example:
http://www.nature.com/cgi-taf/DynaPage.taf?file=/nsmb/journal/vaop/ncurrent/abs/nsmb895.html

A dialog box appears stating "Opening DynaPage.taf". DESCRIPTION inside states that
The file "DynaPage.taf" is of type text/htmlcontent-length:, and Mozilla does
not know how to handle this file type. This file is located at:
http://www.nature.com/cgi-taf/

What should Mozilla do with this file?

* Open it with
* Save it to disk


Reproducible: Always

Steps to Reproduce:

Given above
Actual Results:  

Same dialog box that asks me how to open DynaPag.taf (Type html) or Should
Mozilla save it to disk?

Expected Results:  

It must simply display the HTML page...

Comment 1

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b) Gecko/20050124
Firefox/1.0+

WFM. Do you think that there might have been a typo in the headers or meta tags?
Reporter, are you still seeing this?  If so, do you have pipelining enabled, by
any chance?
(Reporter)

Comment 3

13 years ago
Many thanks for reply. I am not sure if there are errors in "the headers or meta
tags?"

Yes, I have pipelining enabled.
Could you try disabling pipelining?  Does that make the problem go away?
(Reporter)

Comment 5

13 years ago
After I disabled pipelining it loads perfectly. (i.e) success rate 100% as of
today. 
Sounds like a possible server bug....  a lot of servers don't deal well with
pipelining (and this one is sending malformed data back when pipelining is on,
looks like).

Note that I can't reproduce even with pipelining enabled, in a current Linux
trunk build....
Assignee: general → darin
Component: General → Networking: HTTP
Product: Mozilla Application Suite → Core
QA Contact: general → networking.http
Version: unspecified → 1.7 Branch

Comment 7

13 years ago
The sample URL no longer contains any links with "cgi-taf" in them, and the
sample cgi-taf URL in the description just yields an error page. I can't
reproduce a problem with any current links on the site.

molecularbiophysics, are you still experiencing this problem? Can you provide a
new sample URL?
(Reporter)

Comment 8

13 years ago
Yes the website has changed its total structure; there are no "cgi-taf" links in
them. Currently **no** problems with that website. Many thanks.


(In reply to comment #7)
> The sample URL no longer contains any links with "cgi-taf" in them, and the
> sample cgi-taf URL in the description just yields an error page. I can't
> reproduce a problem with any current links on the site.
> 
> molecularbiophysics, are you still experiencing this problem? Can you provide a
> new sample URL?

Comment 9

12 years ago
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking
Version: 1.7 Branch → Trunk

Comment 10

12 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060627 Minefield/3.0a1

Unless you think that there some residual evangelism issue, this is surely closeable as WORKSFORME.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.