Autocomplete crashes in mail compose - TBTrunk [@ nsGenericElement::isSelfOrAncestor][@ nsIContent::GetParent - nsGenericElement::isSelfOrAncestor]

VERIFIED FIXED

Status

()

Core
DOM: Core & HTML
--
blocker
VERIFIED FIXED
13 years ago
7 years ago

People

(Reporter: Scott MacGregor, Assigned: sicking)

Tracking

({crash, smoketest, topcrash})

Trunk
x86
Windows XP
crash, smoketest, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
This was a regression introduced by Bug #279155 last night.

Bring up the compose window. Type in an address with multiple auto complete
matches. Choose a match and hit enter. Application crashes in
nsGenericElement::isSelfOrAncestor. aNode is NULL.

nsIContent::GetParent() line 128 + 3 bytes
nsGenericElement::isSelfOrAncestor(nsIContent * 0x00000000, nsIContent *
0x031ba5f8) line 2669 + 8 bytes
nsXULElement::RemoveChildAt(unsigned int 2, int 1) line 1143 + 23 bytes
nsGenericElement::ReplaceChild(nsGenericElement * const 0x03336cc8, nsIDOMNode *
0x042431c4, nsIDOMNode * 0x031ba614, nsIDOMNode * * 0x0012b954) line 3055 + 17 bytes
nsXULElement::ReplaceChild(nsXULElement * const 0x03336cc8, nsIDOMNode *
0x042431c4, nsIDOMNode * 0x031ba614, nsIDOMNode * * 0x0012b954) line 547 + 24 bytes

Comment 1

13 years ago
This Crash occours in Mozilla-Suite MailNews too. Using latest Nightly:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050125
Mnenhy/0.7.1 {Build ID: 2005012506}

Add Talkback Incident: TB3285013K

Think we have to adjust the Bug-Subject to "Thunderbird and MailNews
Autocomplete crashes in mail compose" or similar.
This is all mine, looking...
Status: NEW → ASSIGNED
I have a patch
Created attachment 172381 [details] [diff] [review]
patch to fix

GetCurrentItem must be returning null. Either way, this is what the code used
to do.
Comment on attachment 172381 [details] [diff] [review]
patch to fix

r+sr=bzbarsky
Attachment #172381 - Flags: superreview+
Attachment #172381 - Flags: review+
Checked in. Scott, please check to make sure that this helped.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

13 years ago
yeah that fixed it. Thank you for the quick turn around. 
awesome, marking verified. Sorry for the regression.
Status: RESOLVED → VERIFIED

Updated

13 years ago
Keywords: crash

Updated

13 years ago
Summary: Thunderbird Autocomplete crashes in mail compose → Thunderbird Autocomplete crashes in mail compose [@ nsGenericElement::isSelfOrAncestor][@ nsIContent::GetParent - nsGenericElement::isSelfOrAncestor]

Updated

13 years ago
Summary: Thunderbird Autocomplete crashes in mail compose [@ nsGenericElement::isSelfOrAncestor][@ nsIContent::GetParent - nsGenericElement::isSelfOrAncestor] → Autocomplete crashes in mail compose [@ nsGenericElement::isSelfOrAncestor][@ nsIContent::GetParent - nsGenericElement::isSelfOrAncestor]
*** Bug 279873 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
Does today's build include this fix?
I guess any build later then 200501251329 should have the fix. I'm not sure when
the nightly builds are made.

Comment 12

13 years ago
Adding topcrash info for future reference.
Keywords: topcrash
Summary: Autocomplete crashes in mail compose [@ nsGenericElement::isSelfOrAncestor][@ nsIContent::GetParent - nsGenericElement::isSelfOrAncestor] → Autocomplete crashes in mail compose - TBTrunk [@ nsGenericElement::isSelfOrAncestor][@ nsIContent::GetParent - nsGenericElement::isSelfOrAncestor]

Comment 13

13 years ago
*** Bug 281686 has been marked as a duplicate of this bug. ***

Updated

9 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: ian → general
Crash Signature: [@ nsGenericElement::isSelfOrAncestor] [@ nsIContent::GetParent - nsGenericElement::isSelfOrAncestor]
You need to log in before you can comment on or make changes to this bug.