If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Force links that open in new windows to open in a new tab" option is broken

VERIFIED WONTFIX

Status

()

Firefox
Tabbed Browser
VERIFIED WONTFIX
13 years ago
13 years ago

People

(Reporter: Stasys Adiklis, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I've enabled browser.tabs.showSingleWindowModePrefs and swithched "Force links
that open in new windows to open in:" to "a new tab".

Yet when i'm shift+clicking a link it still opens in a new window.


Reproducible: Always

Steps to Reproduce:
That's because you're explicitly telling it (with shift) to open a new window.
That feature is going to be revisited in upcoming releases anyways.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
"Single window mode" is single window mode. SINGLE window.

More clues here: bug 279726, comment 6 and here: bug 279726, comment 7.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Single window mode "new tab" option is broken → Single window mode is broken
(Reporter)

Comment 3

13 years ago
There is a related thread (about Single Window Mode) starting with: bug 262459,
comment 6.
(Reporter)

Comment 4

13 years ago
To avoid stupid flames i'm changing severity from a bug to an RFE and summary
from "single window mode is broken" to "true single window mode option".
Severity: normal → enhancement
Summary: Single window mode is broken → True single window mode option
From the summary, this bug is about disabling the Shift-Click functionality in
Single Window Mode. There is nothing to be gained from such a change. If you
don't want a new window, don't use Shift+Click.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → WONTFIX
Summary: True single window mode option → Shift+Click should be disabled in single window mode
(Reporter)

Comment 6

13 years ago
The gain is that link goes out of current tab into another TAB as opposed to
another window. The whole point of a "single window mode" is to ensure that new
windows are not being spawned. To put it in another way: if shift-click forks a
link into a new window in case of a non-tabbed browser (IE), it should fork a
link into a new tab in case of a tabbed browser (in sigle window mode). That's
the logic that both browsers i'm currently using (CrazyBrowser and Tabbrowser
Extensions) follow.

As i suspect you understand "single window mode" a little differently (e.g. you
don't mind that there are multiple windows in a "single window mode"... which is
cool even if ridiculous a little) that's why i've named the idea "TRUE single
window mode". I hope you got it now.

Or shall i submit another RFE that sounds like "option to customize keyboard
shotcuts (such as 'shift-click')"?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Summary: Shift+Click should be disabled in single window mode → True single window mode

Comment 7

13 years ago
First off, please read the rules regarding bugzilla etiquette.
http://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Secondly, shift+click is *intended* to open a new window in Firefox, regardless
of the SWM setting.. Ctrl+Click is modifier for opening a new tab, also
regardless of SWM.

I fail to see why the setting of Single-Window Mode being on, should *alter* and
duplicate keyboard modifiers (I.E. make shift+click do what ctrl+click does.),
this introduces confusing behavior. You seem to think that Firefox should keep
only one window in SWM, which is expected, in general, but when you
*intentionally* use a keyboard modifier to force a new window, that is not
Firefox's issue. Links clicked in the second window should stay as tabs in the
second, same as links in the first should stay as tabs in the first, if a new
window is requested.

Changing the summary of this bug doesn't change what its asking for. This is
still as summarized in Comment #5, and was, IMO, correctly marked as wontfix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

13 years ago
OK, i won't reopen this, however, i will try to explain what was on my mind one
more time (for refenence for GUI designers or smth):


A question:
What are the "links that open in new windows"?

My answer:
If shift is off -> only those that have some pop-up javascript or smth.
If shift is on -> all links.

Therefore, the feature is broken.


I conceived such an interpretation, because the two tabbed browsers i've been
using (Crazy Browser and Tabbrowser Extensions) were apparently using the same
interpretation.
Severity: enhancement → normal
Summary: True single window mode → "Force links that open in new windows to open in a new tab" option is broken
You need to log in before you can comment on or make changes to this bug.