Request for more tabbed browsing options, like those in Galeon

VERIFIED INVALID

Status

()

Firefox
Tabbed Browser
--
enhancement
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: Ingemar Nilsson, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

I would like some more tabbed browsing options, like those found in Galeon. 

One that is very useful is an option to open new tabs from links just to the
right of the current tab rather than at the end of the row. New tabs opened
manually should not be affected by this option. This allows me to do the following:

Open http://www.groklaw.net/ and http://www.slashdot.org/ in two tabs. When I
middle-click on each headline on both sites, the news articles for each site are
kept along the headline page for that site. In the current behaviour, the
articles are opened at the end of the row, which separates them from the main
headline page. This also extends to links on the article pages, since with this
new behaviour, links would be opened just to the right of the article tab, which
improves usability and reduces clutter.

Another useful feature, although somewhat lower priority (in my opinion at
least), would be to allow tabs to be rearranged with the mouse. If I want to
move a tab to some other position in the row, I should be able to just drag it
there.

Both these features were implemented in Galeon 1.3.13, and it would be very nice
to have them here too.


Reproducible: Always

Updated

13 years ago
Whiteboard: DUPEME

Comment 1

13 years ago
Your first request is bug 161836. Your second request is bug 105885. This bug is
invalid because it requests more than one thing. Only one enhancement request
per bug is permitted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.