go to the links above, you are at Basic examples, the first link Layers and Canvas crashed the browser

RESOLVED FIXED

Status

()

Core
SVG
--
critical
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Kemin Zhou, Assigned: tor)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050126
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050126

[root@juno root]# mozilla&
[1] 20057
[root@juno root]# /usr/local/lib/mozilla-1.8b/run-mozilla.sh: line 423: 20065
Segmentation fault      "$prog" ${1+"$@"}
 
[1]+  Exit 139                mozilla
[root@juno root]# mozilla&
[1] 20090
[root@juno root]# x_order_2: colinear!
x_order_2: colinear!
/usr/local/lib/mozilla-1.8b/run-mozilla.sh: line 423: 20098 Segmentation fault
    "$prog" ${1+"$@"}

---
tried several times, using root or regular user account


Reproducible: Always

Steps to Reproduce:
1.don't know what to do
2.Pull the upto minute mozilla from CVS server
3.made the most recent version, still crash



Expected Results:  
Should not crash

Comment 1

14 years ago
This page is 404 Not Found, is that intentional?
(Reporter)

Comment 2

14 years ago
I am sorry, I had a typo error, it is *.shtml, I found this after using
IE.  This page did not crash IE.
It is at the http://www.carto.net/papers/svg/samples
Basic examples
1. Layer and Canvas <-- this link crashes.
Summary: the whole program crashed when opening this document has something to do with SVG viewer → go to the links above, you are at Basic examples, the first link Layers and Canvas crashed the browser

Comment 3

14 years ago
Do you have compiled with SVG support then? Can you provide a stacktrace with
mozilla -g?
(Reporter)

Comment 4

14 years ago
My version was compiled without debug
I have svg compiled in.  I has been layed off for two months and trying to
make some money.  My computer took a long time to compile.  
I also tested http://www.mozilla.org/projects/svg/build.html#linux_libart_dl
It crashed at this links; I thought the recent version would be ok; it that
how I got here.
So, anyone else please do the testing?
I am in survive mode.

mk_add_options MOZ_OBJDIR=/home/kzhou/download/mozilla/objs
mk_add_options MOZ_CO_PROJECT=suite
ac_add_options --enable-application=suite
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --disable-debug
ac_add_options --enable-svg
ac_add_options --enable-svg-renderer-libart
ac_add_options --enable-freetype2
ac_add_options --disable-tests
So the problem here is that nsSVGImageFrame::ConvertFrame ends up with a null
mSurface and doesn't check for that before calling Lock().

Given that nsSVGRendererLibart::CreateSurface is NS_ERROR_NOT_IMPLEMENTED, I
think some error-checks on the return of CreateSurface are in order here...

tor, this is all you, methinks.  ccing pavlov, since he reviewed this code.
Assignee: general → general
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: General → SVG
Ever confirmed: true
Keywords: crash
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: unspecified → Trunk
(Assignee)

Comment 6

14 years ago
Created attachment 173465 [details] [diff] [review]
add error checking
Assignee: general → tor
Status: NEW → ASSIGNED
Attachment #173465 - Flags: review?(pavlov)

Updated

14 years ago
Attachment #173465 - Flags: review?(pavlov) → review+
(Assignee)

Comment 7

14 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.