Unable to clear dependencies and set status to resolved-fixed at the same time

RESOLVED DUPLICATE of bug 271758

Status

()

Bugzilla
Creating/Changing Bugs
--
minor
RESOLVED DUPLICATE of bug 271758
13 years ago
13 years ago

People

(Reporter: Ronald Landheer-Cieslak, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

Using Bugzilla version 2.18rc3
When clearing the set of bugs "this" bug depends on and setting the resolution
to fixed at the same time, Bugzilla refuses to set the resolution to "fixed"
because there are still dependencies.
I have a hunch that the error is that the block of code on lines 1156-1180 of
process_bug.cgi should come after the the block of code on lines 1243-1308 -
i.e. that dependency changes should be affected before the check whether the
form fields can be changed, but I am not quite sure and it seems a bit too
intrusive for me to patch like this..

Reproducible: Always

Steps to Reproduce:
1. Set up dependencies for a bug, making sure it depends on a bug not fixed yet
2. Clear the dependencies and set the resolution to "fixed"
3. commit and see it fail
This will, of course, only work if Bugzilla is set up to check dependencies 

Actual Results:  
Error
	  	
Bug# 294 has still 1 unresolved dependency. Show Dependency Tree.

Please press Back and try again. 

Expected Results:  
Bug processed
	  	
Changes submitted for bug 294
Email sent to: xxxx@xxxx
Excluding: xxxx@xxxx
If you wish to tweak the kinds of mail Bugzilla sends you, you can change your
preferences.
	Back To Bug# 294
Checking for dependency changes on bug 273
Email sent to: no one
Excluding: xxxx@xxxx
If you wish to tweak the kinds of mail Bugzilla sends you, you can change your
preferences.
	Back To Bug# 273
Checking for dependency changes on bug 290
Email sent to: no one
Excluding: xxxx@xxxx
If you wish to tweak the kinds of mail Bugzilla sends you, you can change your
preferences.
	Back To Bug# 290
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
*** This bug has been marked as a duplicate of 271758 ***

*** This bug has been marked as a duplicate of 271758 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.