Clicking on viewpoint / flash screen crashes firefox [@ 0xffff0103 - npViewpoint.dll + 0x1a98]

RESOLVED FIXED

Status

()

Core
Plug-ins
--
critical
RESOLVED FIXED
13 years ago
7 years ago

People

(Reporter: Robert Dohrenburg, Assigned: Brian T. Doherty)

Tracking

({crash, relnote})

Trunk
x86
Windows XP
crash, relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Select any tv size 32, 42, 50 etc then click on the flashplayer window just
below the size menu. Firefox will crash everytime.

Reproducible: Always

Steps to Reproduce:
1.Go to
http://www.sonystyle.com/is-bin/INTERSHOP.enfinity/eCS/Store/en/-/USD/SY_BrowseCatalog-Start?CategoryName=xbr_flat&Dept=tv
2.Select any tv size 32, 42, 50 etc
3.Click on the flashplayer window just below the size menu.

Actual Results:  
Firefox crashes.

Expected Results:  
Load a page?

Firefox is using original theme.
FireFTP exetension is installed.

Updated

13 years ago
Component: Bugzilla-General → General
Product: Bugzilla → Firefox

Updated

13 years ago
Version: unspecified → 1.0 Branch

Updated

13 years ago
Assignee: general → firefox
QA Contact: default-qa → general
Did you submit a Talkback feedback report?  If so, what's the incident ID #?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Did you submit a Talkback feedback report?  If so, what's the incident ID #?

No, I have not submited a talkback report. Should I do that?

I can replicate the bug in other computers. Other people have confirmed the bug
too: see http://www.dslreports.com/forum/remark,12496163~mode=flat

Robert: sorry for being dumb.  I definitely see this, with a 2005-01-28-04 build
of Windows XP using the Viewpoint plugin.

0xffff0103
npViewpoint.dll + 0x1a98 (0x13401a98)
USER32.dll + 0x8709 (0x77d48709)
USER32.dll + 0x87eb (0x77d487eb)
USER32.dll + 0x89a5 (0x77d489a5)
USER32.dll + 0x89e8 (0x77d489e8)
nsAppShell::Run 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp,
line 159]
nsAppStartup::Run 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/components/startup/src/nsAppStartup.cpp,
line 208]
main 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1811]
WinMain 
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1839]
kernel32.dll + 0x16d4f (0x7c816d4f)
Status: UNCONFIRMED → NEW
Component: General → Plug-ins
Ever confirmed: true
Product: Firefox → Core
Version: 1.0 Branch → Trunk
Note that I just filed bug 280212 today, as well.  I wonder if the same bug is
causing these two?
Assignee: firefox → nobody
QA Contact: general → plugins
Keywords: crash
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> Note that I just filed bug 280212 today, as well.  I wonder if the same bug is
> causing these two?

Stephen,

Yes, it looks like it is somehow related.
See also bug 150922 and bug 208555.
Summary: Clicking on flash screen crashes firefox → Clicking on viewpoint / flash screen crashes firefox

Comment 7

12 years ago
*** Bug 306995 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Assignee: nobody → bdoherty
(Assignee)

Comment 8

12 years ago
There was a bug that caused a crash in Firefox when interacting with a 
Viewpoint media player scene. It is fixed in the latest build of the VMP 
(Viewpoint Media player) available at 
https://components.viewpoint.com/MTSInstallers/archive/3_3_0_29/VMPFullInstall_
3_3_0_29.exe but unfortunately the content referred to in this bug report is 
no longer available to verify it's the same issue.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 9

12 years ago
jay: can we see about recommending people upgrade viewpoint if they continue to 
crash with this?
Keywords: relnote
Summary: Clicking on viewpoint / flash screen crashes firefox → Clicking on viewpoint / flash screen crashes firefox [@ 0xffff0103 - npViewpoint.dll + 0x1a98]
Crash Signature: [@ 0xffff0103 - npViewpoint.dll + 0x1a98]
You need to log in before you can comment on or make changes to this bug.