Scrolling of page is inconsistent with mouse wheel.

RESOLVED DUPLICATE of bug 258006

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 258006
13 years ago
12 years ago

People

(Reporter: tom.williams, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20050111
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20050111

When I load the above page, I can scroll the page up and down with the scroll
bar just fine.  When I use the mouse wheel and the mouse pointer is in the
center of the page, it scrolls a little bit when I scroll downward and then
stops.  If the mouse pointer is over the right side of the page (over the unused
page background), the mouse wheel can be used to scroll the page up and down
like the scroll bar.

Reproducible: Always

Steps to Reproduce:
1.Visit this page:
http://www.csszengarden.com/?cssfile=http://adjustafresh.com/zen/mozattack.css
2.Move the mouse pointer in the center of the page and use the mouse wheel to
scroll the page downward
3.It should scroll for a little bit and then possibly stop near the word
"Enlightenment".

Actual Results:  
When using the mouse wheel and the mouse pointer is in the center of the page,
the page starts to scroll and then stops.

Expected Results:  
When using the mouse wheel and the mouse pointer is in the center of the page,
the page should scroll from top to bottom as if using the scroll bars.

This problem does not occur using Firefox 1.0 on Windows 2000. I don't have
access to Mozilla 1.7.5 for additional testing, at this time.
Version: unspecified → Trunk

Comment 1

13 years ago
Confirmed
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050521

Only happens if your mouse is over the knife cutting through the page, if you
move the mouse lower (but still in central text area) scrolling starts agan.

Works in Firefox:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
This appears to be related to css and xhtml, I noticed same issue on 

http://www.cssplay.co.uk/menu/framed.html

in the first two frame layouts linked from that page:

http://www.cssplay.co.uk/menu/background.html

http://www.cssplay.co.uk/menu/background2.html

the last 2 both do allow for mouse wheel scrolling properly.

http://www.cssplay.co.uk/layouts/frame.html

http://www.penname.co.uk/

from comments section of the site, it's not a Suite specific issue, it also affects firefox.

Comment 3

12 years ago
Mouse wheel scrolling stops when the mouse is over a fixed position element.  On the page, sometimes there's another (not fixed-position) element on top of the fixed position one.  But then you scroll down and you're left with the fixed position element (like the blade)

*** This bug has been marked as a duplicate of 258006 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.