Import csv hangs when importing .csv with a quoted "," comma

RESOLVED DUPLICATE of bug 263801

Status

RESOLVED DUPLICATE of bug 263801
14 years ago
14 years ago

People

(Reporter: jpm, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When attempting to import a CSV file through the AddressBook's Import function
it hangs after selecting the CSV file that contains a "," (comma) which was
exported correctly by the AddressBook's export function.

Reproducible: Always

Steps to Reproduce:
1. Create file containing: "Jamie,",Tester,Jamie
Tester,,jamie@tester.com,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
2. attempt to import file
3. the import crashes thunderbird 1.0

Actual Results:  
Thunderbird Crashes

Expected Results:  
Displayed the header / field alignment dialog.
(Reporter)

Comment 1

14 years ago
The csv file was generated by putting "Jamie,"  (without quotes of course) in
the first name field, the export function from Thunderbird automatically quoted
that field as it was being exported as a csv.
Marking as duplicate of bug 263801, the test cases are very similar, and the
result is the same (assuming crash = hang). 

*** This bug has been marked as a duplicate of 263801 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.