If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Downloading to a file that already exists produces broken dialog box

VERIFIED DUPLICATE of bug 277837

Status

SeaMonkey
Download & File Handling
VERIFIED DUPLICATE of bug 277837
13 years ago
13 years ago

People

(Reporter: dmacks, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20050111
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20050111

When downloading a file, for example, from "save to disk" when clicking on a
link for an unknown filetype, trying to overwrite an existing file gives a
dialog box confirming the action, but none of the buttons in it are active.

Reproducible: Always

Steps to Reproduce:
1. In Preferences...Navigator, set:
     Downloads...When saving a file=Prompt for download location
     Helper Applications...application/x-gzip=save it to disk, always ask
2. Open a webpage containing a link to a .gz file, for example,
http://www.mozilla.org/products/mozilla1.x/
3.  Click on a .gz URL (Download Now...Mac OS X, in the above example).
4.  Select Save to disk, click OK in download window.
5.  Save using default name (mozilla-mac-1.7.5.dmg.gz) in file manager window.
6.  Repeat steps 3-5, using the same URL and download location and filename.
Actual Results:  
After step 5, I have the named file on my hard drive. After repeating steps 3-5,
I get a dialog saying that a file by that name already exists, do I want to
replace it. The buttons are marked Cancel (the default) and Replace. Trying to
click either one produces no result. Pressing escape or return gets me back to
the file manager window of step 5. Entering a different name or download
directory allows file in the second pass through step 5 to be saved successfully.

Expected Results:  
I should be able to click "Cancel" to abort the overwrite (and return to the
file manager) or click "Replace" (and file shuold be downloaded and overwrite
the existing one of that name).
this has been fixed already

*** This bug has been marked as a duplicate of 277837 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.