Multi-page print problem with overflow:auto

RESOLVED DUPLICATE of bug 165705

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 165705
13 years ago
13 years ago

People

(Reporter: Thomas, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I have a webpage with "overflow:auto" set in the CSS. When I tried to print it
or print-preview it, I can see only the first page: The webpage is definitely
longer than 1 page, but in the print-preview view, I can only see the first one.
The "next page" button doesn't work, and the number of pages is shown to be 1.

As I remove "overflow:auto", this problem disappears. I never have the same
problem when using IE.

Reproducible: Always

Steps to Reproduce:
1. File -> Print Preview
2.
3.

Actual Results:  
Only the first page is shown. # of pages = 1

Expected Results:  
# of pages to be larger than one, and the rest part is not cut.
(Reporter)

Comment 1

13 years ago
The "overflow:auto" CSS style is set for the BODY element.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 165705 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.