Status

()

Core
CSS Parsing and Computation
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Artem Skoretskiy, Assigned: Blake Ross)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.5) Gecko/20041108 Firefox/1.0

See url. It's CSS 2.1 testcase.
Both boxes must be the same, but they are not.

Reproducible: Always

Comment 1

13 years ago
This is still a first release of the test suite:
"25 Nov 2004
    The first release of the test suite. No report template or test harness yet.
Many tests still missing. This should be considered a “beta” release."
http://www.w3.org/Style/CSS/Test/

FWIW, at the provided URL, I see the same offset in both boxes with Firefox 1.0
build 20041107 and Mozilla 1.8b build 2005021205 under XP Pro. It is true that
the bottom box, there is no padding involved (I checked carefully with DOM
inspector) but this is due to the test itself. 
This rule
.control .orange { border: solid 1em yellow; background: yellow; }
in the test creates a "padding" effect, an 1em offset (same yellow color) due to
border width but there is no css padding involved (in the bottom box).

I checked other CSS2 test suites for padding and did not see any wrong padding
rendering.
E.g.:
http://www.meyerweb.com/eric/css/tests/css2/sec08-04e.htm

Resolving as INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: General → Style System (CSS)
Product: Firefox → Core
Resolution: --- → INVALID
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.