Last Comment Bug 280026 - Text node max length limited to 4K
: Text node max length limited to 4K
Status: RESOLVED DUPLICATE of bug 194231
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: ---
Assigned To: general
: Hixie (not reading bugmail)
: Andrew Overholt [:overholt]
Mentors:
http://www.quirksmode.org/dom/tests/t...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-27 03:51 PST by Mathieu Parent
Modified: 2005-01-27 04:12 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mathieu Parent 2005-01-27 03:51:59 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5) Gecko/20041108 Firefox/1.0

Mozilla's maximum size for a text node is 4K.
When parsing an HTML document, long text are splitted into several 4K nodes.



Reproducible: Always

Steps to Reproduce:
1. go to the URL 
2. Click on the big paragraph
Actual Results:  
Only the first 4K of text are copied. Message:4096 

Expected Results:  
The 64K should be copied. Message:66249.

Mozilla's maximum size for a text node is 4K,
Opera's is 32K,
Explorer Mac seems to have a 64K limit.

(source: www.quirksmode.org)
Comment 1 Jo Hermans 2005-01-27 04:12:40 PST

*** This bug has been marked as a duplicate of 194231 ***

Note You need to log in before you can comment on or make changes to this bug.