Closed Bug 280040 Opened 15 years ago Closed 15 years ago

Nothing displays when body display property set to inline.

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 59837

People

(Reporter: diltsman, Assigned: bugzilla)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 

When this page is displayed:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
	<head>
		<link rel="stylesheet" href="style.css" type="text/css" />
		<title>Anonymous text interrupted bya block</title>
	</head>
	<body>
	This is anonymous text before the P.
		<p>This is the content of P.</p>
		This is anonymous text after the P.
	</body>
</html>

using this stylesheet:
body { display: inline }
p { display: block }

nothing is displayed in the browser window.  A block box is created for the p 
element, as can be seen if the following code is added to the style sheet:
p { border-style: solid }


Reproducible: Always

Steps to Reproduce:
1.Display a page using the code in the detailed explanation.
2.
3.

Actual Results:  
Nothing was displayed.

Expected Results:  
Should have displayed all text as though nothing had happened.

*** This bug has been marked as a duplicate of 59837 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.