"timed out" window INSPECIFIC and USELESS

RESOLVED DUPLICATE of bug 216466

Status

()

RESOLVED DUPLICATE of bug 216466
14 years ago
14 years ago

People

(Reporter: cheif, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

This is probably a bug in a typical situation when we do a search in google and
open many links in NEW windows, only to end up seeing firefox say - "timed out"
in some windows, leaving the user with no idea which window or which page got
timed out. This results in missing many links. So, either firefox ahould give
the user a chance to reload that page with the site address in the address bar,
or atleast give the user a warning... (not with the stupid dialog box!, which
anyway serves no use, because it immediately disappears) ...somewhere, (atleast
on the status bar!) ON THE BLANK TIMED OUT page.. Thank you ! for making firefox
a gem we can all share !

Reproducible: Always

Steps to Reproduce:
1.Look for ANY crashed web site ! and try to open it... 
2.Mozilla will display a "connection timed out for so-so site in a stupid dialog
box which will soon disappear as you hit enter, leaving you with no idea which
site was timed out
3.there is no information about the site which timed out nor any way to
re-establish a connection with it... after the dialog box disappeares..

Actual Results:  
I got angry everytime I saw a billion pages with "timed out" message with no
clue which belonged to which...

Expected Results:  
The software should understand that human beings have only limited memory, and
that they cannot remember which site was timed out if only a dialog box was
shown. the blank timed out page should have contained a link to re-establish a
contact With the server, or atleast give the user an idea which site EXACTLY got
timed out, so the user can follow the link from somewhere else, (if firefox
doesn't allow!) or atleast write it down (or copy paste it, or whatever!) the
valuable link...

ok..ok.. 1 day i'll study all these technical stuff... then we'll see... bah!

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 216466 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.