CSS generated content does not resize dynamically

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: minghong, Assigned: dbaron)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

1.13 KB, application/xhtml+xml
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

CSS generated content (using :before or :after) does not resize dynamically. The
bug appears when part of the document needs larger space than initially loaded,
e.g. after loading a huge image without specifing the width and height.

I'm not sure if this is related to bug 215083.

Reproducible: Always

Steps to Reproduce:
1. Load a page with CSS generated content where the parent element would resize
after loading the (X)HTML.

Actual Results:  
The generated part remains the same in size.

Expected Results:  
The generated part should enlarge as its parent enlarges.

A workaround is to specify the width and height of the parent element.
(Reporter)

Comment 1

14 years ago
Created attachment 172580 [details]
A simple test case

The upper part should look the same as the lower part.
I see the bug on the 1.7 branch and in 1.8a1, but not 1.8a6 or current trunk, so
it seems to be fixed on the trunk sometime after 1.7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.