Customize toolbar feature is not keyboard accessible

NEW
Unassigned

Status

()

Toolkit
Toolbars and Toolbar Customization
P5
minor
13 years ago
3 years ago

People

(Reporter: Aaron Leventhal, Unassigned)

Tracking

({access, sec508})

Trunk
x86
All
access, sec508
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
View -> Toolbars -> Customize requires drag and drop, which requires a mouse.
Keyboard users cannot use it.

On the other hand, keyboard users can't use the toolbar anyway, so this is not a
high priority.

Technically, it could be argued that it is a section 508 bug, so I'm filing it.
(Reporter)

Updated

13 years ago
Priority: -- → P5
(Reporter)

Updated

13 years ago
Blocks: 204402
(Reporter)

Updated

12 years ago
Assignee: aaronleventhal → pilgrim
QA Contact: jruderman → keyboard.navigation
Just got someone in #firefox that wants to hide the search bar because it sometimes truncates the address bar. Also users can hit the url bar and search bar with the keyboard so those two things are at least a problem.  Maybe solved by creating some sort of keyboard accessible toggle (about:config?) for things that can be hit with the keyboard.
(Reporter)

Comment 2

11 years ago
No, just make the customize toolbar feature key navigable.

Comment 3

7 years ago
looks like [alt]View->Toolbars->Customize with their access keys does it..
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
There's no way to do the actual customizing, though...
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Assignee: pilgrim → nobody
Status: REOPENED → NEW

Updated

7 years ago
Duplicate of this bug: 679037

Comment 6

7 years ago
My window manager doesn't allow drag and drop, so it is impossible to add, remove and change the position of icons in the Navigation Toolbar.

Comment 7

7 years ago
Is it possible to edit a file in the profile folder to customize the toolbar?

Comment 8

3 years ago
Firefox has stopped using this feature and now has its own customizable toolbars page... which is also not keyboard accessible. Someone else then filed a bug about that (bug 1116578), and so because one of these has to go to toolkit (no use keeping both around just for Firefox and 0 for toolkit), it seems more logical to move this one as that's what this bug was always about.
No longer blocks: 204402
Component: Keyboard Navigation → Toolbars and Toolbar Customization
Product: Firefox → Toolkit
Version: unspecified → Trunk

Updated

3 years ago
See Also: → bug 1116578
You need to log in before you can comment on or make changes to this bug.