Java scripts SVG methods and properties not supported on Mozilla ver 1.8

RESOLVED INVALID

Status

()

Core
SVG
--
blocker
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Satyajit Tripathi, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4.1) Gecko/20031008
Build Identifier: Mozilla 1.8

The List of the methods not working in Mozilla are
1.currentScale  
2.currentTranslate
3.getBBox


currentScale -  This is required to get the present position of the SVG and then
the value is used for zooming of the SVG graph

currentTranslate - This is required for panning of the SVG area.

getBBox() - This returns the rectangle around an object as SVGrect object. We
can then get the X and Y coordinates and also the width and height of the
rectangle and with these values perform other calculations( mainly for getting
the scroll bars).

Reproducible: Always

Steps to Reproduce:
NOTE: website http://pilat.free.fr/english/routines/js_dom.htm gives the
information of the above properties and methods.
Actual Results:  
Whenever the browser encounters these methods it throws an error that these
methods are not valid.

Expected Results:  
These properties should return the values for 

o CurrentScale should return the scale (a number)
o currentTranslate should return the SVGpoint 
o getBBox() should return the rectangle object
there is no 1.8 (the latest version is 1.8alpha6). which version did you
actually use?
Assignee: jag → general
Component: XP Apps → SVG
Product: Mozilla Application Suite → Core
QA Contact: ian
Version: unspecified → Trunk
also... in the future, please file separate bugs for separate issues

Comment 3

13 years ago
All three indicated methods are implemented in the current SVG code.
Build or download a current build and file bugs if you discover
problems with their implementation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
*** Bug 280183 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.