Closed Bug 280195 Opened 15 years ago Closed 14 years ago

Text field (Folder field) in Custom Install option "Browse For Folder" does not show complete path

Categories

(Firefox :: Installer, enhancement)

x86
Windows 2000
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 233746

People

(Reporter: nosaku, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The text field (Folder field) in Custom Install option "Browse For Folder" does
not show complete path. It simply show "Mozilla Firefox". Also the directory
browser above the text field shows the TEMP path where the installer is extracted.

Reproducible: Always



Expected Results:  
1. Instead of showing just the "Mozilla Firefox", it is better if the complete
path is shown. For example, "C:\Program Files\Mozilla Firefox". This makes
easier for the user to just change the install location by typing in text field.
For example if I want to install in "D:\Program Files\Mozilla Firefox", I can
just change the driver letter from C: to D:
2. The directory browser above the text field shows the TEMP path where the
installer is extracted. It becomes difficult to navigate to "Program Files" or
other locations from there. Instead it is better to show the path "C:\Program
Files\Mozilla Firefox". (Default).
Blocks: 282239
No longer blocks: 282239
Blocks: 282239
Blocks: 233625, 245392, 281235
No longer blocks: 245392
No longer blocks: 281235
(In reply to comment #0)
> 2. The directory browser above the text field shows the TEMP path where the
> installer is extracted. It becomes difficult to navigate to "Program Files" or
> other locations from there. Instead it is better to show the path "C:\Program
> Files\Mozilla Firefox". (Default).

Related to Thunderbird bug 251424?
Assignee: bugs → nobody
QA Contact: bugzilla → installer
In the future please only report one problem per bug. Having more than one
problem makes it more difficult to resolve the bug properly.

The first reported issue is bug 233746. The second reported issue is bug 241282.
As the first issue is still a bug resolving this bug as a dupe of bug 233746.

*** This bug has been marked as a duplicate of 233746 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
No longer blocks: 233625
This bug was marked a duplicate of one which is the duplicate of another which was marked "WONTFIX". I think the WONTFIX was because it was Windows9x or NT.

This bug is 2000. 

Should it then be reopened?
You need to log in before you can comment on or make changes to this bug.