Closed Bug 280199 Opened 15 years ago Closed 14 years ago

Extension Installer creates abs: Paths in compreg.dat that are incompatible with Portable Firefox

Categories

(Toolkit :: Startup and Profile System, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tchurm, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041001 Firefox/0.10.1 (MOOX M2)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041001 Firefox/0.10.1 (MOOX M2)

as a big fan of running firefox from my USB memory stick, i frequently come
across cases where many extensions (especially XPCOM extensions perhaps?) write
absolute paths ('abs:') in the profile's compreg.dat file.

this means that when i plug my USB drive into another computer, and it's
assigned a different drive letter, the extension is unusable...because firefox
searches for the extension files using the (now) invalid absolute path.

can't all paths to files in compreg.dat and in chrome.rdf (and elsewhere) be
replaced with relative paths, so that extensions will run on portable firefox?

btw, at the URL listed above is a sample firefox installation slightly modified
for running on a USB stick...please test it yourself...just unzip to the root of
any drive (such as a usb stick drive).

Reproducible: Sometimes

Steps to Reproduce:
1.create a Firefox installation that runs from a USB Stick or use Portable Firefox
2.install an XPCOM component like WML Browser or Forecast Fox
3.run the extension (it'll work) but then move the USB stick to a different
drive (or get it assigned to a different drive letter) and then try to run the
extension...it'll no longer work

Actual Results:  
Extension failure

Expected Results:  
Extension should run properly

also a pain - each time i install a new extension on my firefox-for-usb
installation, i have to change in:

Firefox\Firefox_Data\Profiles\default.uyw\chrome\chrome.rdf

replace:

jar:file:///[Drive Letter]:/Firefox/ProfileDirectory/	...

with:

jar:resource:/ProfileDirectory/	...

==please==

keep the firefox running free on usb
This also creates problems when trying to make deployments using FFDeploy.exe.
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → Windows XP
Blocks: 196119
*** Bug 292618 has been marked as a duplicate of this bug. ***
I believe this should be product Toolkit and component XRE Startup. Also, though
the paths can still be absolute the compreg.dat file is now regenerated under
additional conditions.
Component: Extension/Theme Manager → XRE Startup
Product: Firefox → Toolkit
This now WFM, we regenerate compreg whenever the install directory is not the same as it was at last launch.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Component: XRE Startup → Startup and Profile System
QA Contact: bugs → startup
You need to log in before you can comment on or make changes to this bug.