Setting border-collapse to collapse in table and setting overflow to hidden in containing div hides left and top border in table.

RESOLVED DUPLICATE of bug 155955

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 155955
14 years ago
14 years ago

People

(Reporter: rajesh dubey, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; GIS IE6.0 Build 20031007; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 Gecko/20041107 FireFox/1.0

A Table with style "border-collapse" set to "collapsed" is contained in a div
that has overflow set to hidden.
This causes the top and left border of table to be invisible. 

Reproducible: Always

Steps to Reproduce:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html 
     PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
     "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<title>test</title>
<style type="text/css">
table {border-collapse:collapse;
	border:1pt solid black;
	font-family: Times New Roman, sans-serif;
	font-style: normal;
	font-weight: normal;
	font-size: 10pt;
	line-height: 0.170in;}
table * td {border:0.5pt solid black;
		padding:0px;
		margin:0;
		padding:0px;}
table * th {text-align:left;
		border:0.5pt solid black;
		padding:0px;
		margin:0;}
</style>
</head>
<body>
	<div> This table with style "border-collapse" set to "collapsed" is 
contained in a div <br />
		that has overflow  set to hidden.<br />

		This causes the top and left border of table to be invisible.
		<br />
		<br />
	</div>
	<div  style="overflow:hidden;">
	<table >
		<col width="2in" />
		<col width="3in" />
		<thead>

			<tr>
			<th>Head1</th>	
			<th>Head2</th>	
			</tr>
		</thead>
		<tbody>
			<tr>
				<td><div style="width:2in;">AAAAAAAAAAAAAAA 
AAAAAAAAAA AAAAAAAAAAAAAA1</div></td>

				<td><div style="width:3in;">BBBBBBBBBBBBBB 
BBBBBBBBBBB BBBBBBBBBBBBBBB1</div></td>
			</tr>
			<tr>
				<td><div style="width:2in;">AAAAAAAAAAAAAA 
AAAAAAAAAAA AAAAAAA AAAAAAA1</div></td>
				<td><div style="width:3in;">BBBBBBBBBBBB 
BBBBBBBBBBBBB BBBBBBBBBBBBBBB1</div></td>
			</tr>
		</tbody>

	</table>
	</div>
	<div> This table with style "border-collapse" set to "collapsed" is 
contained in a div that doesn't have overwrite:hidden set.<br />
		This displays the border.<br />
		This means that setting border-collapse to collapse affects 
left and top position of table.
		<br />
		<br />
	</div>

	<div>
	<table style="border:1px black solid;">
		<col width="2in" />
		<col width="3in" />
		<thead>
			<tr>
			<th>Head1</th>	
			<th>Head2</th>	
			</tr>

		</thead>
		<tbody>
			<tr>
				<td><div style="width:2in;">AAAAAAAAAAAAAAA 
AAAAAAAAAA AAAAAAAAAAAAAA1</div></td>
				<td><div style="width:3in;">BBBBBBBBBBBBBB 
BBBBBBBBBBB BBBBBBBBBBBBBBB1</div></td>
			</tr>
			<tr>
				<td><div style="width:2in;">AAAAAAAAAAAAAA 
AAAAAAAAAAA AAAAAAA AAAAAAA1</div></td>

				<td><div style="width:3in;">BBBBBBBBBBBB 
BBBBBBBBBBBBB BBBBBBBBBBBBBBB1</div></td>
			</tr>
		</tbody>
	</table>
	</div>
</body>
</html>



Actual Results:  
check out the html provided in steps to reproduce..

Expected Results:  
check out the html provided in steps to reproduce..

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 155955 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.