Closed Bug 28021 Opened 20 years ago Closed 20 years ago

Setting to fonts choosen by page, can crash browser.

Categories

(SeaMonkey :: Preferences, defect, P3, critical)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: jlarsen, Assigned: matt)

Details

(Keywords: crash)

1. Start browser with setting of use my default fonts.
2. have a page loaded and something in the url bar (this is not nessesarly 
required. but helps in generating a crash)
3. In preferences/fonts switch to using fonts choosen by page.
4. Hit ok.    
              About 10% of the time browser will crash here.
5. Try and highlight url.
              About 50% of the time the highlighting will act verty strange
6. Close browser.
              About 80% of the time browser will crash during closing with 
message of

MOZILLA caused an invalid page fault in
module RDF.DLL at 0167:606ab4fa.
Registers:
EAX=00000000 CS=0167 EIP=606ab4fa EFLGS=00010246
EBX=00000045 SS=016f ESP=0068fbbc EBP=0068fc54
ECX=008eb280 DS=016f ESI=00000000 FS=160f
EDX=606d5ee0 ES=016f EDI=008eb280 GS=0000
Bytes at CS:EIP:
8b 08 ff 51 2c ff 77 08 e8 75 95 02 00 ff 0d c8 
Stack dump:
00000000 008eb280 008eb730 008eb280 606ab4af 00000000 606ab54c 00000001 607329a2 
008eb280 008eb730 006a4594 60732809 008ecd90 60732c85 00000001


This same message appears if the crash happends in stage 4.

If not error, restart browser, try again.. It tends to not 
error at all about 5% of the time
Changing component to Preferences.
Assignee: neeti → matt
Component: Preferences: Backend → Preferences
Sairuh,
Have you notice this happening?
Is the build you're using from before 1/29, e.g., M13?  Then this might be a
duplicate of bug 24581.
Sorry, forgot to report build#, but no I'm talking about todays build 
2000.02.16.08 for windows 98
Severity: major → critical
Keywords: crash
Summary: [Crash]Setting to fonts choosen by page, can crash browser. → Setting to fonts choosen by page, can crash browser.
http://bugzilla.mozilla.org/show_bug.cgi?id=27824
similiar crashing bug but i have yet to reproduce it
hm, on win98 using the opt bits for 2000022208, i cannot repro this. adding 
paulmac to cc list as he uses win98 more often than me...
This bug seems to have magically dissapeared. Though there still seems to be a
problem associated with highlighting edit fields when this is switched. Will
resubmit as a different bug. No longer crashes though. New bug
http://bugzilla.mozilla.org/show_bug.cgi?id=297092
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
correction.. that is http://bugzilla.mozilla.org/show_bug.cgi?id=29072  :)
verif.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.