page at http://cplus.about.com/ is displayed wrongly

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Scott, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In the page at http://cplus.about.com/od/beginnerctutorial/l/aa020502a.htm,
several question marks (�����) show up where it appears that tabs should
actually be. So if a paragraph begins with a tab then Firefox displays '�����'

I looked at this same page in IE and Opera and the question marks do not show.

Reproducible: Always

Steps to Reproduce:
1. Goto http://cplus.about.com/od/beginnerctutorial/l/aa020502a.htm
2. Look for this sentence: �����As part of compilation, the C++ compiler runs a
program
3. Each line that should beign with a tab begins with ����� instead

Actual Results:  
�����As part of compilation, the C++ compiler runs a

Expected Results:  
     As part of compilation, the C++ compiler runs a

Comment 1

13 years ago
Character encoding detected by FF is Western (Windows-1252)

WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050909
Firefox/1.6a1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Summary: http://cplus.about.com/od/beginnerctutorial/l/aa020502a.htm → page at http://cplus.about.com/ is displayed wrongly
(Reporter)

Comment 2

13 years ago
This may be a different issue requiring a new bug entry, but the page at
http://cplus.about.com/od/cprogrammin1/l/bldef_mutable.htm displays question
marks (?????) within the code sample. IE and Opera do not display the question
marks and instead display what look like tabs.

I am running Firefox 1.0.7 on Windows XP SP2.

Thanks, -Scott
Status: RESOLVED → UNCONFIRMED
OS: Windows 2000 → Windows XP
Resolution: WORKSFORME → ---

Comment 3

13 years ago
(In reply to comment #2)
> This may be a different issue requiring a new bug entry, but the page at
> http://cplus.about.com/od/cprogrammin1/l/bldef_mutable.htm displays question
> marks (?????) within the code sample. IE and Opera do not display the question
> marks and instead display what look like tabs.
> 
> I am running Firefox 1.0.7 on Windows XP SP2.
> 
> Thanks, -Scott

That page works for me too on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.9a1) Gecko/20050921 Firefox/1.6a1
Please try the latest trunk if you can.
Version: unspecified → 1.0 Branch
Assignee: bross2 → nobody
Resolving as WFM based on the comments. If you see this issue again (the pages have since changed) and can reproduce with Firefox 2.0.0.3 or later and with a new profile, please file a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.