Error saving international characters and mathematical symbols

RESOLVED DUPLICATE of bug 212158

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 212158
14 years ago
14 years ago

People

(Reporter: lawmay, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Notes which refer to section "Steps to Reproduce":

(A) Firefox has no trouble displaying the URLs (1)(a)-(b) from the web, only
saving them to hard disk.

(B) I am able to save the URLs (1)(a)-(b) to hard disk error free using MS
Internet Explorer 6.0.2800.1106 SP1; Q867801; Q833989. If I do, Firefox displays
these saved html files error free.

Reproducible: Always

Steps to Reproduce:
1. Go to either of the following 2 URLs:
(a)
http://www.aidsonline.com/pt/re/aids/fulltext.00002030-200010200-00027.htm;jsessionid=B2f60poNtiae7KhQaDToLLKkbGwD1TRoXwZJ1DxYSql23DEa0YGu!-1907902876!-949856032!9001!-1?&fullimage=true
(b)
http://www.jaids.com/pt/re/jaids/fulltext.00126334-200202010-00017.htm;jsessionid=B2lT23YopFhi5b1tXJwqYTAgcvoRWWVVBvkEEO06t5GrFvwZLSkk!-1907902876!-949856032!9001!-1?&fullimage=true

2. Save the URL to hard disk via File-Save Page As-Web Page,Complete

3. Go offline using File-Work Offline

4. Clear cache using Tools-Options-Privacy-Clear Cache

5. Open the html file you saved to harddisk in step (2) above.

6. Alternatively, steps (3)-(5) can be performed with another (non Firefox)
browser such as MS Internet Explorer.
Actual Results:  
International characters and mathematical symbols are screwed up, being replaced
by a variety of garbage symbols.


(I) I'm using Windows 2000 SP4 build 2195.

(II) My bug does NOT appear the same (but may be related to)
https://bugzilla.mozilla.org/show_bug.cgi?id=260695 , where I see no mention of
international characters or mathematical symbols. Moreover, I have never seen
any duplicate contents (Double header and double bottom).

(III) My bug appears unrelated to
https://bugzilla.mozilla.org/show_bug.cgi?id=253842 . That bug has to do with
errors in the NAMES of saved files. My bug has to do with errors in the CONTENTS
of saved files.

Comment 1

14 years ago
There is no charset specified in the document, but the server do that in the
HTTP response header:
"Content-Type: text/html;charset=UTF-8"

So the page display correctly from the network, but the local file is displayed
with the default character encoding (ISO-8859-1). Setting the encoding to UTF-8
in View ->Character Encoding, or using View -> Character Encoding -> Auto-Detect
-> Universal corrects the problem.

Duping against bug 212158. 



*** This bug has been marked as a duplicate of 212158 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.