Keyboard controls on drop down lists don't work as expected

VERIFIED DUPLICATE of bug 27661

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 27661
18 years ago
18 years ago

People

(Reporter: Rick Elliott, Assigned: karnaze (gone))

Tracking

({regression})

Trunk
x86
Windows NT
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The down arrow key on an HTML form drop down list doesn't only scroll through
the list, as on 4.x, but rather, scrolls the whole window. This is in addition
to scrolling through the list, though the results are rather entertaining (for
about a minute)

Find a form with a drop down list (like this new bug form).
Select the list, then try to down arrow through the choices.
See the entire list move down the page as the rest of the page scrolls up.

Comment 1

18 years ago
Testing with 2000-02-21-08-M14 and 2000-02-22-08-M14 on WinNT, this is now 
worse - nothing happens at all initially, and when something does happen,
the arrowkeys get *only* to the page.:

Steps to Reproduce:
1. Cloase any running Mozilla windows and restart Mozilla.
2. View a page with <SELECT>s, like, say, this one.
3. Click on the down-arrow at the right side of a <SELECT>.
4. Try to use the up/down arrowkeys.
5. Click on any item in the <SELECT>.
6. Click on the down-arrow at the right side of *any* <SELECT>.
   (Best seen with the "Resolve bug, changing resolution to" <SELECT>
    in the middle of the screen vertically)
7. Try to use the up/down arrowkeys.

Actual Results:
The selected item on the list does not scroll, either in step 4 or step 7. 
The page does scroll in step 7, while the list breaks free (detaches) and 
stays put. Occassionally, on pressing [Up] after holding [Dn] down for several 
repeats, the highlighted item will change.

Expected Results:
The selected item on the list does scroll up or down the list, in step 4 and
in step 7. The page does not move.
Keywords: regression

Comment 2

18 years ago
Argh. Looked for the earlier bug that I was sure was there, and then saw it 
just after pressing [Commit]. This is a DUP of bug 27661, "navigating in 
combo/list box causes entire page to scroll", M14.


*** This bug has been marked as a duplicate of 27661 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.