Download Manager Progress Bar shows negative size when downloading size > 2Go

VERIFIED DUPLICATE of bug 228968

Status

()

VERIFIED DUPLICATE of bug 228968
14 years ago
10 years ago

People

(Reporter: bofself, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When I "save link as" this dvd iso file
ftp://fr2.rpmfind.net/linux/fedora/core/3/i386/iso/FC3-i386-DVD.iso, it
downloads correctly but if the downloaded data exceeds 2 Go, size and download
rate become negative.
 

Reproducible: Didn't try

Steps to Reproduce:
1. Save link as tp://fr2.rpmfind.net/linux/fedora/core/3/i386/iso/FC3-i386-DVD.iso
2. Wait until the downloaded data exceeds about 2 Go.

Actual Results:  
It displays negative file size and negative downloading rate.

Expected Results:  
It should display the correct file size, even if the size > 2 Go.

Please ask me for screenshot if needed.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 228968 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.