If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pressing Cmd+W twice closes the whole window (rather than just the last two tabs)

RESOLVED DUPLICATE of bug 155702

Status

()

Core
Keyboard: Navigation
--
major
RESOLVED DUPLICATE of bug 155702
13 years ago
13 years ago

People

(Reporter: Prognathous, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
BeOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Steps to reproduce:
1. Launch Firefox or Mozilla (any recent build should do)
2. Open about 15 tabs
3. Hold Cmd (Alt) pressed
7. Press 'W' twice (very quickly)

Expected result: The last two tabs should close
Actual result: The whole window is closed

I've managed to reproduce this problem with a fresh installation of BeOS R5 Pro
(updated only with the 5.03 patch and BONE 7a). I see it both P3 450MHz as well
as with AMD Duron 850Mhz.

To anyone on the CC list, if you can't reproduce this, please post your machine
specs and BeOS configuration, so this bug can be isolated.

Thanks,

Prog.

Comment 1

13 years ago
It works for me. What build are you using?

Comment 2

13 years ago
Works for me too - Athlon XP 2400+

I wouldn't call it "major" either - assuming it works alright for you if you
just leave a little pause between each key press.

I'm not using BONE.
(Reporter)

Comment 3

13 years ago
(In reply to tqh, comment #1)
> It works for me. What build are you using?

Seamonkey:
Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.8a) Gecko/20040519
Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.7a) Gecko/20041216
Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.8a5) Gecko/20041218

Firefox:
Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.8b) Gecko/20050119 Firefox/1.0+

This problem happens with all the above, and with previous builds as well.

(In reply to Simon, comment #2)
> Works for me too - Athlon XP 2400+

I wonder if this could this be related to the relatively slow machines I'm using?
 
> I wouldn't call it "major" either - assuming it works alright for you if you
> just leave a little pause between each key press.

Well, it happens to me very frequently. The only reason I specified to press
Cmd+W "very fast" was because I knew some people had problems reproducing this,
and I knew it happens more frequently when there's no pause between the presses.
Having content in the tabs also makes the problem appear more frequently.

As for not being a "major" bug, i agree. It's a "critical" one ("Critical -
crashes, loss of data, severe memory leak"). I *have* lost data due to this bug.
I'll live Severity as "major" for the time being, you may change it if you feel
it's fitting.

> I'm not using BONE.

I'm almost certain that it happens with Netserver as well. I can install
BeOS-sans-BONE on another partition if further testing is needed.

Prog.

Comment 4

13 years ago
I'm wondering why you ignoring our enumerous and intensive discussion and didn't
even put here URL of original bug i gave you:
https://bugzilla.mozilla.org/show_bug.cgi?id=155702
It contains enough explanation to understand what and why happens.

Comment 5

13 years ago
marking duplicate

*** This bug has been marked as a duplicate of 155702 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

13 years ago
Sergei, I wasn't CCed to that bug, but I do recall you mentioning that you're
familiar with the problem (and I've mentioned that in the blog, too bad you
didn't notice it). Now, should this be a dupe, or should it be-reopned to deal
with the short-interval behavior?

Prog.

Comment 7

13 years ago
duuno. Reason is same. Cmd-W generates QuitRequested for active Window, and this
is the reason. 
So we should change that assignment in BeZilla, or think about more tricky hack.
Personally i dislike idea about using same shortcut for using for both tab and
window closing. it contradicts with mozilla own behaviour - see, if you close
tabs using close button, for last tab it removes tab panel, but don't close window.
Actually i refused to use Cmd-W for tab closing not because your version of bug,
but because i "lost" my data several times when used automatically Cmd-W with
single last tab opened.
maybe there is sense to use Ctrl+T for closing, when Alt+T is in use fro
creating? and vice versa.
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)
> Personally i dislike idea about using same shortcut for using for both tab and
> window closing. it contradicts with mozilla own behaviour - see, if you close
> tabs using close button, for last tab it removes tab panel, but don't close
window.

When Cmd+W is pressed when only one tab is open this not a critical issue, as it
won't cause any unexpected dataloss. It *is* important though that Cmd+W/Accel+W
(rather than any other modifier key) would close the current tab, as this is
what happens in virtually all browsers that support tabs - Mozilla and Firefox
for all platforms, Safari, Camino, Opera and so on.

Pressing Accel+W should never close the whole window when more than one tab is
open, that's what other shortcuts are for - e.g. Cmd+Shift+W in Camino/Safari
and Alt+F4 in all tabbed Windows browsers.

Prog.

Comment 9

13 years ago
I've got a better solution to this - but as this has been marked a dupe I'll put
it in the old bug:
Bug 155702
You need to log in before you can comment on or make changes to this bug.