Firefox Crashes when closing the popups with javascript:window.close(); function

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: James Norris, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8b) Gecko/20050124 Firefox/1.0+ (MOOX M3)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8b) Gecko/20050124 Firefox/1.0+ (MOOX M3)

when browsing the junk mail folder, there is an option to empty the folder. This
button produces a pop-up with a check box for reporting the mail as junk when
you delete the messages. This popup causes firefox to crash when it closes,
weather you close it yourself or wait for it to close itself.

Reproducible: Always
(Reporter)

Comment 1

13 years ago
Seems to only happen if you select the checkbox to report as junkmail. Otherwise
the popup closes fine and doesn't affect ff.
(Reporter)

Comment 2

13 years ago
Also, nevermind. I guess you can close this bug... It seems this only occurs on
non-Mozilla branded builds. Tried on the official nightly and not getting the
problem. More recent Moox builds (and If I recall correctly, also on mmoy and
bangbang builds) however, do show this problem.

Comment 3

13 years ago
I tried this out and can't reproduce it on Firefox CE Trunk 2004-12-23 K8A-X13.
Could you tell me which of my builds it crashes on?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> I tried this out and can't reproduce it on Firefox CE Trunk 2004-12-23 K8A-X13.
> Could you tell me which of my builds it crashes on?

Yes :o)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8a6) Gecko/20041228
Firefox/1.0+ (FireFox Comm Ed Trunk 2004-12-23 P4W-X9)

Though, that seems to have the same date as your build... 

Comment 5

13 years ago
I was unable to reproduce this problem with the build that you mentioned though
someone else was able to reproduce it on the official nightly builds but only
with certain extensions installed. The conversation is being continued at

http://www.moox.ws/forum/viewtopic.php?p=1619#1619

for any interested parties.
(Reporter)

Comment 6

13 years ago
Seems this was an extension problem *feels stupid*
problem seems to exist in a few extensions which is what made me rule it out as
this in the first place. One culprit is miniT. Continuing the discussion in
relevent extensions forums, thanks for your help, Michael.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Summary: Firefox Crashes when closing the popup for reporting junk mail at hotmail.com → Firefox Crashes when closing the popups with javascript:window.close(); function
You need to log in before you can comment on or make changes to this bug.