Firefox should treat the desktop lockdown (/desktop/lockdown is the GCONF key) setting under GNOME

RESOLVED DUPLICATE of bug 321315

Status

()

Firefox
Shell Integration
--
enhancement
RESOLVED DUPLICATE of bug 321315
14 years ago
13 years ago

People

(Reporter: Ganesh, Assigned: wolfiR)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0

Firefox should treat the desktop lockdown (/desktop/lockdown is the GCONF key)
setting under GNOME desktop environemnt.The keys are
disable_printing,disable_print_setup,disable_save_to_disk.

Reproducible: Always

Steps to Reproduce:
1.Set disable_printing to true in GCONF.
2.Open firefox.
3.

Actual Results:  
Printing not disabled in firefox.

Expected Results:  
Printing should be disabled.
(Reporter)

Comment 1

14 years ago
Created attachment 172933 [details] [diff] [review]
patch V1

This is a work in progress patch. I am sure we would need some #ifdefs here.
+// GNOME desktop lockdown settings

Don't say "GNOME". The prefs should exist on all platforms, even if they're only
used by GNOME at first.

+pref("config.lockdown.printing",false);
+pref("config.lockdown.printsetup",false);
+pref("config.lockdown.savepage",false);

I don't think these should go in "config". "lockdown" probably deserves its own
section. Maybe "lockdown.disable.printing", etc?

I think you should have one Mozilla lockdown pref for each GNOME lockdown pref.
These prefs should exist on all platforms. Then all your browser.js changes can
run on all platforms. On all platforms but GNOME, these prefs will always be
false. (Although people might start using them on other platforms later.)
(Assignee)

Comment 3

14 years ago
+  if(gPrefService.getBoolPref("config.use_system_prefs"))
+    gconfLockdown();

Why should it be only honored then?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

14 years ago
OK..We could have these lockdown preference in its own section. Then I believe
we shouldn't bother about config.use_system_prefs to honour the lockdown
settings right?.
Right. The browser should always honour the lockdown settings. But those
settings will always be 'false' unless something turns them on (e.g., gconf).
(Assignee)

Comment 6

13 years ago
Created attachment 182765 [details] [diff] [review]
reworked patch with changed pref names

Robert, Mike: I take this bug for now. Please tell me what's still missing.
(I will try in the meanwhile to get a Thunderbird patch together)
(Assignee)

Updated

13 years ago
Assignee: bugs → mozilla
Attachment #172933 - Attachment is obsolete: true
Status: NEW → ASSIGNED
(Assignee)

Comment 7

13 years ago
will be fixed with bug 321315

*** This bug has been marked as a duplicate of 321315 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.