Replace "REGEXP" with Bugzilla::DB function call

RESOLVED FIXED in Bugzilla 2.20

Status

()

--
enhancement
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Tomas.Kopal, Assigned: Tomas.Kopal)

Tracking

unspecified
Bugzilla 2.20
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050110 Firefox/1.0 (Debian package 1.0+dfsg.1-2)
Build Identifier: 

"REGEXP" and "NOT REGEXP" are MySQL specific and should be replaced with DB
agnostic call to function in the DB compatibility layer.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Updated

14 years ago
Blocks: 280493
(Assignee)

Comment 1

14 years ago
Created attachment 173948 [details] [diff] [review]
V1

Patch replacing REGEXP and NOT REGEXP operators with functions from DB
compatibility module.
(Assignee)

Updated

14 years ago
Attachment #173948 - Flags: review?
Comment on attachment 173948 [details] [diff] [review]
V1

r=wurblzap by inspection.
Attachment #173948 - Flags: review? → review+

Updated

14 years ago
Assignee: general → Tomas.Kopal

Updated

14 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Bugzilla 2.20

Comment 3

14 years ago
Should be approved after the base dbcompat patch is approved.
Flags: approval?
I understand from Max that these changes are relatively low risk for MySQL users
and have gone through multiple levels of revision and review, but I'm concerned
about their impact, so please be around in the days after checking this in to
watch out for and respond to reports of regressions caused by the checkins.
Flags: approval? → approval+

Comment 5

14 years ago
Checking in editusers.cgi;
/cvsroot/mozilla/webtools/bugzilla/editusers.cgi,v  <--  editusers.cgi
new revision: 1.75; previous revision: 1.74
done
Checking in Bugzilla/Search.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Search.pm,v  <--  Search.pm
new revision: 1.76; previous revision: 1.75
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.