selecting nothing does not clear instance data

RESOLVED DUPLICATE of bug 278207

Status

Core Graveyard
XForms
RESOLVED DUPLICATE of bug 278207
13 years ago
2 years ago

People

(Reporter: Allan Beaufour, Assigned: Allan Beaufour)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

13 years ago
Use "testcase" in bug 278207, and try deselecting everything. It does not clear
the instance data as it should.

Comment 1

13 years ago
I found the problem.  Once the fix goes in for 278207, it is about a two line
fix.  I no longer need to zero out the bound node before calling
WriteSelectedItems since it no longer puts stuff into the bound node, but just
returns the string that SHOULD go in it.  Then I also need to remove the test
for the string buffer coming back empty and set the node value on the bound node
regardless if the buffer is empty or not.  Being empty should be fine, the
condition where nothing is selected.

This approach will fix the problem.  There is something odd whereas after I
select and then deselct the 2nd item in the list, nothing will be selected, but
the deselected cursor will go back to the first item in the list.
Status: NEW → ASSIGNED

Comment 2

13 years ago
since I had to update the patch to 278207 anyhow, just included this fix into
that patch.

*** This bug has been marked as a duplicate of 278207 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.