Closed Bug 28055 Opened 20 years ago Closed 20 years ago

Charset reflection for Reply & Forward/inline is broken

Categories

(MailNews Core :: MIME, defect, P3, critical)

All
Windows 98
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: momoi, Assigned: nhottanscp)

References

Details

(Keywords: regression, Whiteboard: [PDT+])

Attachments

(1 file)

** Observed with 2/16/2000 Win32 build **

As nhotta explained in Bug 23540, his fix there broke the 
Mime charset reflection functionality in case the default
send charset set by the new menu item does not match the
charset of the original msg which is being replied to or
forwarded as inline.

This needs to be fixed so that rhp's fix for M14 work
as intended. This bug also blocks verification of Bug 3979.
Mrked dependency.
Blocks: 3979
Keywords: beta1, regression
QA Contact: lchiang → momoi
Accepting, I have a fix for this (will attach the patch).
Status: NEW → ASSIGNED
Corrected the summary line typo.
Summary: Chrset reflection for Reply & Forward/inline is broken → Charset reflection for Reply & Forward/inline is broken
*** Bug 28080 has been marked as a duplicate of this bug. ***
Putting on the PDT+ radar for beta1.
Whiteboard: [PDT+]
Fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
** Checked with 2/22/2000 Win32 build **

When I verified rhp's charset reflection (Bug 3979), I set 
the default to Japanese and tried some 16 other charsets. 
They all worked. That indiactes that this fix is working.
Marking it verified/fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.