Closed Bug 280624 Opened 16 years ago Closed 16 years ago

rfc2047 header encoded "," breaks email-address apart

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: vogelchr, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041221
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041221

If I get email from someone with "surname, name" encoded via rfc2047 in the
From:-header, mozilla breaks apart that name at the comma, even if it is inside
the rfc2047 encoding.

Example:
   From: =?ascii?Q?Some=2C_Guy?= <nobody@example.com>
Or (real world example):
   From: =?iso-8859-1?Q?R=F6ll=2C_Sven?= <email@ddress.omitted>


Reproducible: Always

Steps to Reproduce:
1. send email for example via smtp:

  > From: =?ascii?Q?Some=2C_Guy?= <nobody@example.com>
  > To: user@example.com
  > Subject: test

2. read that email with mozilla
Actual Results:  
The email-list view shows only the first part in front of the comma: "Some" or
"Röll".

The email's headers view shows only the part after the comma, "Guy" or "Sven".

Expected Results:  
Both the headers and the list view should show "Some, Guy" or "Röll, Sven".

http://www.faqs.org/rfcs/rfc2047.html says:

   IMPORTANT: 'encoded-word's are designed to be recognized as 'atom's
   by an RFC 822 parser.

So I would not expect an address to be broken by any chacater which is rfc2047
encoded.

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.