If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla hangs when trying to open Attach File window

RESOLVED DUPLICATE of bug 240644

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED DUPLICATE of bug 240644
13 years ago
4 years ago

People

(Reporter: jordi martinez, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

The first step is to work with Mozilla Mail component in a local network to
attach files from this network. It all works OK.
Then you take your laptop and bring it to another place and connect to the local
network. This one might have different local IP addresses or it might not (I
checked both cases).
When you try to attach a new file, Mozilla hangs. It probably tries to open the
Attach File window in the last IP location it opened at, and if this IP address
is not reachable in the network (because it is a different network!), it hungs.


Reproducible: Always

Steps to Reproduce:
1. Connect to a local network and attach a file from anywhere but not your local
PC into an e.mail. 
2. Send this e.mail with the file attached.
3. Disconnect your PC and connect to another network, where the IP
address/network location from you took the last file to attach does not exist.
Mozilla hangs.

Actual Results:  
Mozilla hung.

Expected Results:  
It should open up a new window without trying to remember the last location the
user used to locate a file to attach to a new e.mail.

Modern theme.

My laptop is using Windows XP Professional SP2. I use static IP addresses
everywhere I work in, because I am a technical consultant and connect my laptop
(always the same) to different local networks. I change manually my IP address
every time.

The problem occurs even if the same IP address segment (i.e. 192.168.0.*) is
used in different locations.

Updated

13 years ago
Summary: Mozilla hangs when trying to open Attach File window → Mozilla hangs when trying to open Attach File window
Whiteboard: DUPEME
Version: unspecified → 1.7 Branch

Comment 1

13 years ago
Workaround:

Mozilla seems to save the path of the last file attached in the prefs.js, to be
found in your profile directory. Simply edit the line shown below and enter a
valid path, e.g. "C:\\temp":
user_pref("mail.compose.attach.dir", "C:\\temp");

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 240644 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.