onResize event not fired in unfocused browser tabs

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Chris Cook, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Unfocused browser tabs do not seem to receive onResize events. If Gmail is open
in one tab but another tab is focused and the window is resized then when you
switch back to the Gmail tab the layout is not updated. A page reload is
required to get Gmail to update its layout.

Reproducible: Always

Steps to Reproduce:
1. Open Gmail (or any webpage that executes a script onResize) in a browser tab.
2. Create a second browser tab and make it active.
3. Resize the browser window.
4. Switch back to the first tab and observe that the script did not execute.
I've also seen this with Firefox 1.0, and 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050203 Firefox/1.0+

Instead of a page reload, a second window resize is sufficient to reflow the page.

Fallout from bug 227361 ?
Yes, very likely.
Blocks: 227361
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
I think this is WFM now, not?

Comment 5

13 years ago
I think this bug goes beyond the onresize event.  When I load a tab with, for example, Bank of America and quickly go to a new or different tab before the page loads.  After loading the page I come back to the tab, the focus is not in the textbox as it should be - as it would had I never left the tab.

earl.bobby@gmail.com, that's a different bug. I suggest you file a new bug for that (if it doesn't already exist).
*** Bug 335096 has been marked as a duplicate of this bug. ***
Created attachment 233286 [details]
testcase

1. open in another tab
2. note no size reported
3. switch to different tab.
4. resize
5. switch back to the tab with the testcase.
6. note the size has been updated.
wfm 1.5.0.6/2.0b1 winxp.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.