Closed Bug 280856 Opened 15 years ago Closed 15 years ago

some table definitions are altered *after* the --TABLE-- limit in checksetup.pl

Categories

(Bugzilla :: Installation & Upgrading, defect, P1, minor)

2.19.2

Tracking

()

RESOLVED FIXED
Bugzilla 2.20

People

(Reporter: LpSolit, Assigned: mkanat)

References

()

Details

Attachments

(1 file, 1 obsolete file)

In checksetup.pl, there is a comment which specifies that:

# If you had to change the --TABLE-- definition in any way, then add your
# differential change code *** A B O V E *** this comment.

This is at line 4237. But there is code starting at line 4540 which still alters
table definitions. We should correct this as checksetup.pl is already hard
enough to read. ;)
*** Bug 285119 has been marked as a duplicate of this bug. ***
Assignee: zach → mkanat
Severity: trivial → minor
Priority: -- → P1
Target Milestone: --- → Bugzilla 2.20
Attachment #176572 - Flags: review?(LpSolit)
Blocks: bz-dbinstall
Blocks: 285121
*** Bug 280395 has been marked as a duplicate of this bug. ***
Comment on attachment 176572 [details] [diff] [review]
Put all checksetup table stuff in the right place

I missed a few.
Attachment #176572 - Attachment is obsolete: true
Attachment #176572 - Flags: review?(LpSolit)
Comment on attachment 176572 [details] [diff] [review]
Put all checksetup table stuff in the right place

Nevermind, I'm a liar. This is fine. :-)
Attachment #176572 - Attachment is obsolete: false
Attachment #176572 - Flags: review?(LpSolit)
Status: NEW → ASSIGNED
Attachment #176572 - Flags: review?(LpSolit) → review?(bugzilla)
*** Bug 285523 has been marked as a duplicate of this bug. ***
Attachment #176572 - Attachment is obsolete: true
Attachment #176572 - Flags: review?(bugzilla)
Attachment #176572 - Attachment is obsolete: false
Attachment #176572 - Flags: review?(bugzilla)
OK, this one actually does a little more than cut-and-paste. It moves two
blocks into the places that they should have been originally. I've looked over
the code, and I've tested it, and they work properly in these locations.

The classifications code will always work, because the classifications table is
guaranteed to exist by that point (same as the products table for TestProduct).


The "derive regex" block was moved so that the behavior will be consistent with
MySQL and PostgreSQL after I put this section into a MySQL-only block in bug
285121. It should have always been where I am now putting it; reading the bug
that creates it says that it was placed there as a "just in case," but that is
now a problem (in that it creates inconsistency).
Attachment #176572 - Attachment is obsolete: true
Attachment #176971 - Flags: review?(bugzilla)
Attachment #176572 - Flags: review?(bugzilla)
Comment on attachment 176971 [details] [diff] [review]
Move code to the correct places

r=glob
Attachment #176971 - Flags: review?(bugzilla) → review+
Flags: approval?
Flags: approval? → approval+
Checking in checksetup.pl;
/cvsroot/mozilla/webtools/bugzilla/checksetup.pl,v  <--  checksetup.pl
new revision: 1.369; previous revision: 1.368
done
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.