Last Changed Date column header wastes space

RESOLVED FIXED in Bugzilla 2.20

Status

()

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: psellhorst, Assigned: annevk)

Tracking

unspecified
Bugzilla 2.20
Bug Flags:
approval +

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In previous Bugzilla versions, the default header text for the column
containing the date on which a bug was last changed was "Changed". Now it's
"Last Changed Date". While the new text is, obviously, technically more
accurate, it also wastes space - either horizontally (leaving less room
for the other columns) or vertically (increasing the header height,
leaving less room for the bug rows).

Since you're already using the concept of shortening column headers to better
fit their typical column contents for columns such as Sev(erity) or Pri(ority),
I suggest changing the title back to "Changed". Dates are almost always much
shorter than the string "Last Changed Date".


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 173224 [details]
Screenshot (new vs. old)

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

14 years ago
Would "Last modified" be ok? As it is used in the bug? Could you also give an
example of a query that returns that column.
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> Would "Last modified" be ok? As it is used in the bug? Could you also give an
> example of a query that returns that column.

I think that "Last modified" is still a little longer than necessary.
Compare:

Changed
Last modified
Mon 05:36

Moreover, since it's two words, it may cause an unwanted line break,
therefore my suggestion still is:

Last Changed Date -> Changed
Open Date         -> Opened

Example query:
https://bugzilla.mozilla.org/buglist.cgi?product=Firefox&chfieldfrom=1d&chfieldto=Now&columnlist=changeddate,assigned_to,bug_status,resolution,short_short_desc&order=bugs.delta_ts
(Assignee)

Comment 4

14 years ago
Created attachment 174489 [details] [diff] [review]
patch #1

Something like this?
Assignee: myk → bug
Status: NEW → ASSIGNED
Attachment #174489 - Flags: review?(myk)
Comment on attachment 174489 [details] [diff] [review]
patch #1

Yes, this looks good.
Attachment #174489 - Flags: review?(myk) → review+
(Assignee)

Updated

14 years ago
Flags: approval?
Flags: approval? → approval+

Comment 6

14 years ago
Checking in template/en/default/global/field-descs.none.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/field-
descs.none.tmpl,v  <--  field-descs.none.tmpl
new revision: 1.6; previous revision: 1.5
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.20
You need to log in before you can comment on or make changes to this bug.